Bug 846365

Summary: Dual head on intel mobile 945gm (not mirrored)
Product: [Fedora] Fedora Reporter: Phil <support>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 17CC: ajax, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-20 11:50:20 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Phil 2012-08-07 10:56:14 EDT
Description of problem:
Connecting an external monitor has no effect. When attempting to turn the monitor on(in display settings) the system becomes extremely slow/unusable. Turning the monitor off returns the system to a usable state.

Version-Release number of selected component (if applicable):
3.4.0-1.fc17.i686
xorg-x11-drv-intel 2.20.1-1.fc17
glibc 2.15-51.fc17

How reproducible:
always

Steps to Reproduce:
1.connect monitor
2.system settings->display->ON
3.experience uber-slowness
  
Actual results:


Expected results:
dual-head non-clined

Additional info:
The external works fine on it's own if I invoke Fn+F5. See full explanation of symptoms: http://lists.fedoraproject.org/pipermail/users/2012-July/422209.html
Comment 1 Adam Jackson 2012-08-20 11:50:20 EDT
Yeah, well, i945's terrible like that.  i915 and i945 have a limitation in their hardware acceleration where they can't work on surfaces that are more than 2048 pixels wide.  Presumably enabling dualhead is causing you to exceed that limit, and then all your drawing hits software fallbacks.

*** This bug has been marked as a duplicate of bug 699705 ***
Comment 2 Phil 2012-08-23 10:59:49 EDT
I don't agree that this is a duplicate. I've experienced the 2048 pixel and although this does still exist since I have that chipset the symptoms I was refering to are not those of bug 699705. In bug 699705 the monitor automatically switches on but in doing so renders the system unusable if the display is set to 2048 or more. To avoid that I had my display settings below that limitation to avoid those symptoms. My external monitor would not turn on.

Case in point I just updated to 3.5.2-3.fc17.i686kernel 3.5 and connecting an external monitor now works. I'm still stuck within 2048 horizontally but at this point I'll take what I can get ;) My workaround for this has always been to stack my monitors vertically. It's akward if you're accustom to having them the other way but it works!

Thanks
Phil