Bug 847206

Summary: <p/> renders with content outside tags
Product: [Community] Publican Reporter: Joshua Wulf <jwulf>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.0CC: lcarlon, rglasz, rlandman, xma
Target Milestone: 3.1   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 3.1.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-05 22:40:38 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Joshua Wulf 2012-08-10 01:33:37 EDT
Description of problem:

Publican 3 renders <para> content outside <p/> tag in HTML output.

To Reproduce:

publican create --name test
cd test
publican build --formats=html-single --langs=en-US

open tmp/en-US/html-single/index.html

Examine source.

Actual Result:

<div class="para"><p></p>
			This is a test paragraph in a section
		</div>


Expected Result:

<div class="para"><p>This is a test paragraph in a section</p>
			
		</div>
Comment 1 Jeff Fearn 2012-08-17 02:55:12 EDT
This will produce invalid HTML due to the way content can be nested in DocBook.

e.g.

<div class="para">
<p>
 This is a test paragraph in a section
 <div class="this could be a table">
  <table>...</table>
 </div>
</p>
</div>

We could remove the <p/> if it's causing problems.
Comment 2 Jeff Fearn 2012-08-17 02:56:05 EDT
Added DOCTYPE to intermediate XML file.

To ssh://git.fedorahosted.org/git/publican.git
   dffbfa2..621c7b9  master -> master
Comment 3 Jeff Fearn 2012-08-17 02:57:33 EDT
Ignore comment 2, wrong bug :(
Comment 4 Jeff Fearn 2012-11-06 21:37:05 EST
Remove the P?
Comment 5 Joshua Wulf 2012-11-07 00:12:40 EST
That would seem to make the most sense. If it can't be reliably used to wrap the content, then it's spurious.
Comment 6 Jeff Fearn 2013-01-07 19:04:44 EST
This fix has been committed to the devel branch for inclusion in Publican 3.1.
Comment 7 xuezhi ma 2013-01-31 01:17:37 EST
Verify version: publican-3.1.0-0.el6eng.noarch -> PASS

Verify steps:
1. $publican create --name=test
2. $cd test/
3. $publican build --formats=html-single --langs=en-US
4. Check the style of "this is a test paragraph" in Chapter1

Actual results:
<p> and </p> are removed