Bug 849778

Summary: link GraphicsMagick against lcms2 instead of lcms1
Product: [Fedora] Fedora Reporter: Gerd v. Egidy <gerd>
Component: GraphicsMagickAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: andreas, rdieter, thibault.north
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-07 07:34:41 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
patch to change GM to lcms2 none

Description Gerd v. Egidy 2012-08-20 16:10:50 EDT
Created attachment 605774 [details]
patch to change GM to lcms2

Description of problem:

GraphicsMagick can be linked either against version 1 or version 2 of the little color management system (lcms), but not against both at the same time. If some other program links GraphicsMagick and lcms, it can not link against another version of lcms than GM.

Currently GM is linked agains lcms1. So a program needing GM and lcms2 can not be correctly packaged for Fedora without hacks like statically linking another version of GM, but that goes against the packaging guidelines for good reason. I want to package photivo (http://photivo.org/) which has exactly this problem (see e.g. http://code.google.com/p/photivo/issues/detail?id=58).

This is why I propose to change GM to use lcms2 in a future Fedora release. At best F18, but if that is too late F19.

I have checked all programs needing GM in F18:

[root@f18 ~]# repoquery --whatrequires GraphicsMagick
GraphicsMagick-c++-0:1.3.16-3.fc18.i686
GraphicsMagick-c++-0:1.3.16-3.fc18.x86_64
GraphicsMagick-devel-0:1.3.16-3.fc18.i686
GraphicsMagick-devel-0:1.3.16-3.fc18.x86_64
GraphicsMagick-perl-0:1.3.16-3.fc18.x86_64
dvdauthor-0:0.7.0-7.fc18.x86_64
octave-6:3.6.2-3.fc18.i686
octave-6:3.6.2-3.fc18.x86_64
php-pecl-gmagick-0:1.1.0-0.5.RC2.fc18.x86_64
vdr-skinenigmang-0:0.1.2-8.fc18.x86_64
vdr-text2skin-0:1.3.2-10.fc18.x86_64                                                                                                                     
I have modified GM with the attached patch. Then I downloaded and rebuilt all the mentioned RPMs. I did a short test with each of them. Everything fine.

After that I also checked all of them for the use of lcms:
grep -r lcms ~/rpmbuild/BUILD
Only GM itself showed up. So I'm pretty confident that no program currently in the Fedora repository uses lcms1 or 2.

I also read that GraphicsMagick upstream plans to drop support for lcms1.

So please apply the attached patch, outline what need to be checked before this can be done or propose another solution to package a program needing GM and lcms2.
Comment 1 Thibault North 2012-08-20 16:30:05 EDT
I second that.

The patch is straightforward and the impact is minimal. Please apply.
Thanks,
Comment 2 Fedora Update System 2012-08-20 23:49:00 EDT
GraphicsMagick-1.3.16-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.16-5.fc18
Comment 3 Fedora Update System 2012-08-20 23:50:03 EDT
GraphicsMagick-1.3.16-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.16-5.fc17
Comment 4 Fedora Update System 2012-08-20 23:51:14 EDT
GraphicsMagick-1.3.16-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.16-5.fc16
Comment 5 Rex Dieter 2012-08-20 23:56:05 EDT
if you want any koji buildroot overrides in the meantime, let me know.
Comment 6 Fedora Update System 2012-08-21 00:52:48 EDT
Package GraphicsMagick-1.3.16-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing GraphicsMagick-1.3.16-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12333/GraphicsMagick-1.3.16-5.fc18
then log in and leave karma (feedback).
Comment 7 Gerd v. Egidy 2012-08-21 03:35:24 EDT
wow, that was fast. Thank you.

I see that you switched F16 and F17 too. Don't you fear breaking some app a user got built from elsewhere? Or do you think that not likely because there are very few programs out there using GM and lcms?
Comment 8 Rex Dieter 2012-08-21 07:28:43 EDT
oh, you're right, hmmm... it is true nothing in f16/f17 links GM/lcms at the same time, so let's give it a try.
Comment 9 Fedora Update System 2012-09-07 07:31:12 EDT
GraphicsMagick-1.3.16-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-09-07 07:34:41 EDT
GraphicsMagick-1.3.16-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-09-17 19:48:39 EDT
GraphicsMagick-1.3.16-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.