Bug 850811 (CVE-2012-2864)

Summary: CVE-2012-2864 mesa: Arbitrary code execution via unspecified vectors related to 'array overflow'
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: airlied, ajax
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=important,public=20120821,reported=20120822,source=cve,cvss2=6.8/AV:N/AC:M/Au:N/C:P/I:P/A:P,rhel-5/mesa=notaffected,rhel-6/mesa=notaffected,fedora-all/mesa=affected
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-30 00:55:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 851006, 852644, 852645    
Bug Blocks: 850815    

Description Jan Lieskovsky 2012-08-22 09:18:05 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2012-2864 to the following vulnerability:

Mesa, as used in Google Chrome before 21.0.1183.0 on the Acer AC700, Cr-48, and Samsung Series 5 and 5 550 Chromebook platforms, and the Samsung Chromebox Series 3, allows remote attackers to execute arbitrary code via unspecified vectors that trigger an "array overflow."

References:
[1] http://code.google.com/p/chromium/issues/detail?id=141901 (private)
[2] http://googlechromereleases.blogspot.com/2012/08/stable-channel-update-for-chrome-os.html
Comment 2 Huzaifa S. Sidhpurwala 2012-08-23 01:14:32 EDT
Upstream patch:
http://www.mail-archive.com/mesa-dev@lists.freedesktop.org/msg25207.html
Comment 3 Huzaifa S. Sidhpurwala 2012-08-23 01:24:20 EDT
Created mesa tracking bugs for this issue

Affects: fedora-all [bug 851006]
Comment 8 Huzaifa S. Sidhpurwala 2012-08-30 00:55:49 EDT
This issue affects the version of mesa package as shipped with Fedora-17.

Statement:

Not Vulnerable. This issue does not affect the version of mesa as shipped with Red Hat Enterprise Linux 5 and 6.