Bug 850813

Summary: gtkglext requires pangox, and pangox is no more.
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: gtkglextAssignee: Ralf Corsepius <rc040203>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: mpetch, rc040203
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-28 01:22:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 914061, 992448    

Description Hans de Goede 2012-08-22 13:20:34 UTC
gtkglext links to, and makes other package link to (through its pkg-config file) pangox, but since pango-1.31 pangox has been retired.

Comment 1 Hans de Goede 2012-08-22 13:21:56 UTC
Also see bug 516588, where removing the pangox dep was discussed "a while ago", but unfortunately never got fixed.

Comment 2 Ralf Corsepius 2012-08-22 13:38:03 UTC
(In reply to comment #1)
> Also see bug 516588, where removing the pangox dep was discussed "a while
> ago", but unfortunately never got fixed.

And I don't have anything to add.

* pangox is still in rawhide - The package builds fine.

* What do you suggest to use instead of pangox?
  Patches welcome

* Fedora/RH can not "simply remove" packages, because they are "dead upstream" or because "upstream" wants it to be removed.

Comment 3 Hans de Goede 2012-08-22 13:50:43 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Also see bug 516588, where removing the pangox dep was discussed "a while
> > ago", but unfortunately never got fixed.
> 
> And I don't have anything to add.
> 
> * pangox is still in rawhide - The package builds fine.

pangox is no longer part of pango since this build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=349749

Which is why I filed this bug.

> * What do you suggest to use instead of pangox?

They way I read bug 516588, gtkglext is not actually using functionality from it, just
accidentally linking against it. I could be wrong though :)

Comment 4 Ralf Corsepius 2012-08-22 14:18:50 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Also see bug 516588, where removing the pangox dep was discussed "a while
> > > ago", but unfortunately never got fixed.
> > 
> > And I don't have anything to add.
> > 
> > * pangox is still in rawhide - The package builds fine.
> 
> pangox is no longer part of pango since this build:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=349749

Read again what I wrote above: 
RH cannot simply abandon packages, which are in use.

Or differently, it's only the fact pangox is part of Gnome2 which enables RedHat to remove this package. If it was of arbitrary origin, you'd likely not have filed this BZ and share my opinion on what you are doing.

> Which is why I filed this bug.
> 
> > * What do you suggest to use instead of pangox?
> 
> They way I read bug 516588, gtkglext is not actually using functionality
> from it, just
> accidentally linking against it. I could be wrong though :)
I need to check, but IIRC, from the last time I checked, believe you to be wrong.

Comment 5 Michael Petch 2013-08-18 15:36:56 UTC
The latest git version of gtkglext (a couple years old) doesn't rely on pangox

Comment 6 Ralf Corsepius 2013-08-18 15:58:57 UTC
(In reply to Michael Petch from comment #5)
> The latest git version of gtkglext (a couple years old) doesn't rely on
> pangox

Which gtkglext are you referring to?

Comment 7 Michael Petch 2013-08-18 16:05:33 UTC
git clone git://git.gnome.org/gtkglext   as mentioned at https://projects.gnome.org/gtkglext/download.html .

Comment 8 Ralf Corsepius 2013-08-27 17:53:19 UTC
(In reply to Michael Petch from comment #5)
> The latest git version of gtkglext (a couple years old) doesn't rely on
> pangox

The unreleased version in git is ABI/API incompatible to gtkglext-1.2.0.
More precisely, it doesn't "not rely on pangox", it has the whole bunch of functions and functionality which currently are implemented through pangex removed.

This means it would break a lot of packages and cause a lot of problems, in Fedora and in different upstreams.

That said, I do not consider the upstream version to be an option[1], but will resort to using pangox-compat in Fedora.


[1] Formally, I am still one of the upstream maintainer, however the whole project actually is stalled, partially because of lack of agreement on how to handle the functional regressions the Gnome project has caused by abandoned pangox and partially because of dissatisfaction with the Gnome project in general.