Bug 851223

Summary: "Failed to load children for node" error message on GUI
Product: [Other] RHQ Project Reporter: Armine Hovsepyan <ahovsepy>
Component: Core UIAssignee: RHQ Project Maintainer <rhq-maint>
Status: NEW --- QA Contact: Mike Foley <mfoley>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 4.5CC: hrupp, jshaughn, mfoley
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 707223    
Attachments:
Description Flags
CannotLoadChildrenForNode
none
server.log none

Description Armine Hovsepyan 2012-08-23 10:17:12 EDT
Created attachment 606609 [details]
CannotLoadChildrenForNode

Description of problem:
Sometimes while clicking on infinispan resource red error with text "Failed to load children for node" is being thrown on GUI. 

Version-Release number of selected component (if applicable):
JON 3.1.1 ER3

How reproducible:
just twice - both in IE8

Steps to Reproduce:
1. Start eap server and inventory in jon
2. click on infinispan resource in resources tree
3.
  
Actual results:
Exception is being shown on GUI

Expected results:
No exception is shown on GUI

Additional info:
Please get attached the screenshot and fragment form log. Couldn't reproduce by my own, was visible just twice and with no special case.
Comment 1 Armine Hovsepyan 2012-08-23 10:17:31 EDT
Created attachment 606610 [details]
server.log
Comment 2 Jay Shaughnessy 2012-08-23 17:25:48 EDT
There isn't much to go on.  The error was generated on the server, the GUI is just reporting the failure.

The attached server log doesn't show much, I'm not sure if there was more context before or after the exception.  But it looks like some sort of network glitch or something.  We need to figure out if this is related to this one type of call or just endemic to the environment.
Comment 3 Armine Hovsepyan 2012-08-24 04:01:49 EDT
Hi Jay,

Same exception has been thrown on click of EAP_Server on UI. There was no other exception visible in logs. Will update the BZ with comment in case of reproduction with more "informative" log.