Bug 851739

Summary: nouveau related hang when using 3.5.x kernels
Product: [Fedora] Fedora Reporter: Gerard Ryan <gerard>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: airlied, ajax, anders.blomdell, bskeggs, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-08 08:08:10 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
video
none
picture of black screen with dmesg-esque messages
none
dmesg output from a working kernel (3.4.6-2.fc17.x86_64)
none
dmesg output from a problematic kernel (3.5.2-3.fc17.x86_64) none

Description Gerard Ryan 2012-08-24 20:42:15 EDT
Created attachment 606973 [details]
video

Description of problem:
On all of the 3.5.x kernels that have reached Fedora 17 stable, I've been encountering this problem that I never had with any kernel previous to it. I resume my laptop from suspend, and in less than 5 minutes, the screen goes black, and some dmesg-style messages related to nouveau appear. Then it seems to try to recover, but alternates between the black screen with the nouveau messages, and a messed up unusable screen with my work/applications. Since I was unable to do anything else, I've attached a photo and a video of what I mean. In the photo, you can see the messages related to nouveau failing. In the video, the alternating between to and from the kernel messages can be seen.

Version-Release number of selected component (if applicable):
3.5.x

How reproducible:
100% on my hardware.

Steps to Reproduce:
1. Boot with a kernel from the 3.5.x branch from Fedora stable repositories
2. Suspend
3. Resume from suspend, and do something for a brief period (if I do nothing, nothing happens: it seems to be only when I'm doing stuff).
  
Actual results:
Computer becomes unusable and alternates to a black screen with dmesg-style output.


Expected results: This is not expected to happen.


Additional info:
Since the output indicates that this has something to do with nouveau, here's the relevant line from `lspci -nnvv` for my graphics card:

01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Dell Device [1028:022e]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at f2000000 (64-bit, non-prefetchable) [size=32M]
	Region 5: I/O ports at ef00 [size=128]
	[virtual] Expansion ROM at f4000000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nouveau


dmesg output from a working and non-working kernels will be attached.

Thanks!
Comment 1 Gerard Ryan 2012-08-24 21:22:16 EDT
Created attachment 606974 [details]
picture of black screen with dmesg-esque messages
Comment 2 Gerard Ryan 2012-08-24 21:23:59 EDT
Created attachment 606975 [details]
dmesg output from a working kernel (3.4.6-2.fc17.x86_64)
Comment 3 Gerard Ryan 2012-08-24 21:30:37 EDT
Created attachment 606976 [details]
dmesg output from a problematic kernel (3.5.2-3.fc17.x86_64)
Comment 4 Gerard Ryan 2012-08-31 10:31:08 EDT
FYI: This bug still happens with kernel-3.5.3-1.fc17 from updates-testing
Comment 5 Gerard Ryan 2012-10-08 08:08:10 EDT
This no longer happens from kernel-3.5.5-2.fc17. Closing issue! :)