Bug 85210

Summary: kickstart fails with LVM partitions from ananaconda-ks.cfg
Product: [Retired] Red Hat Linux Reporter: Alexios Hadji <ahadji>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED NOTABUG QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-22 16:30:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alexios Hadji 2003-02-26 17:41:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a)
Gecko/20021207 Phoenix/0.5

Description of problem:
I installed a system using the standard 8.0 cd's and used LVM, and the system
worked.  When I tried to kickstart the same machine using the anaconda-ks.cfg
file which had been autogenerated, I got an error and the installer suggested
that I report it to bugzilla.

I added "clearpart --all" and ucommented the partioning lines which had been
autogenerated but commented out and chose to do an ftp installation, otherwise
the ks.cfg file was the original.

I saved the dump output to disk.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot linux ks=floppy (with auto-generated ks.cfg file)
2.
3.
    

Actual Results:  installer reports error "Unhadled Exception Occurred"
"PartitioningError: Adding this partition would not leave enough disk space for
already allocated logical vo
lumes in Volume00."

Expected Results:  System should have installed correctly.

Additional info:

ks.cfg:

cod0 is an 18gig drive
cod1 is a 36gig logical volume from compaq array (hardware raid 3X18gig)

all the partitions should fit on the first drive.

# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --all
part /boot --fstype ext3 --size=128 --ondisk=ida/c0d0
part swap --size=2048 --ondisk=ida/c0d0
part pv.14 --size=100 --grow --ondisk=ida/c0d1
part pv.13 --size=100 --grow --ondisk=ida/c0d0
volgroup Volume00 pv.13 pv.14
logvol / --fstype ext3 --name=root --vgname=Volume00 --size=256
logvol /usr --fstype ext3 --name=usr --vgname=Volume00 --size=3072
logvol /var --fstype ext3 --name=var --vgname=Volume00 --size=1024
logvol /home --fstype ext3 --name=home --vgname=Volume00 --size=2048
logvol /tmp --fstype ext3 --name=tmp --vgname=Volume00 --size=512




I don't know what exactly you need from the dump.  Here are some parts.  Tell me
if you need more.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/text.py", line 402,
in run
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
251, in curren
tStep
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
150, in gotoNe
xt
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
215, in moveSt
ep
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/autopart.py", line
1084, in doAut
oPartition
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/autopart.py", line
1033, in doCle
arPartAction
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/autopart.py", line
950, in doPart
itioning
PartitioningError: Adding this partition would not leave enough disk space for
already allocat
ed logical volumes in Volume00.

Comment 1 Michael Fulbright 2003-04-02 20:56:01 UTC
Could you start with the /tmp line and start commenting them out going up until
it will install? I can't seem to reproduce this issue, and knowing which of the
requests is causing the error would help.

Comment 2 Michael Fulbright 2003-04-22 16:30:08 UTC
Closing due to inactivity. If you have new information to add please reopen the
issue report.