Bug 852897

Summary: qemu-kvm crash in validate_surface
Product: [Fedora] Fedora Reporter: Jerry James <loganjerry>
Component: spiceAssignee: Hans de Goede <hdegoede>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 17CC: alevy, alexl, amit.shah, berrange, cfergeau, crobinso, djasa, dwmw2, hdegoede, itamar, jforbes, knoel, kraxel, marcandre.lureau, pbonzini, rjones, sandmann, scottt.tw, stephent98, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-03 10:03:47 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Backtrace generated by abrt, which it fails to parse none

Description Jerry James 2012-08-29 17:56:23 EDT
Created attachment 608006 [details]
Backtrace generated by abrt, which it fails to parse

Description of problem:
I have a Fedora 18 x86_64 VM running on a Fedora 17 x86_64 host.  I use spice to display the guest.  Today, after installing the latest updates from updates-testing on the guest, I did some other work on the host for awhile.  When I came back, the screensaver was on.  I exited the screensaver, got just a quick glimpse of the guest's desktop, and this crash happened.

I should really just turn off the screensaver in the guest, but then I wouldn't have found this problem.

I cannot report this with abrt, because of this error:

--- Running analyze_LocalGDB ---
Analyzing coredump 'coredump'
All debuginfo files are available
Generating backtrace
Backtrace is generated and saved, 10779 bytes
Backtrace parsing failed for .
26:0: "Thread" header expected


Version-Release number of selected component (if applicable):
qemu-system-x86-1.0.1-1.fc17.x86_64

How reproducible:
Always (or at least, it happened on 2 out of 2 attempts just now).

Steps to Reproduce:
1. Create a Fedora 18 machine, with all updates from updates-testing applied
2. Display the machine on a Fedora 17 host with spice
3. Wait for the guest's screensaver to kick in
4. Type the user's password to exit the screensaver.
  
Actual results:
Qemu-kvm crashes.

Expected results:
Qemu-kvm stays up.

Additional info:
The command line is:
/usr/bin/qemu-kvm -S -M pc-0.15 -cpu core2duo,+lahf_lm,+rdtscp,+popcnt,+sse4.2,+sse4.1,+pdcm,+xtpr,+cx16,+tm2,+est,+vmx,+ds_cpl,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds -enable-kvm -m 1024 -mem-prealloc -mem-path /dev/hugepages/libvirt/qemu -smp 2,sockets=2,cores=1,threads=1 -name Fedora18-64 -uuid 9ef29e25-55b2-d298-609d-1ba217ec1e4e -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Fedora18-64.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/dev/vg_diannao/lv_F18_64,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=21,id=hostnet0,vhost=on,vhostfd=22 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:3c:54:fe,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

Also, I see this in /var/log/libvirt/qemu/Fedora18-64.log:
validate_surface: failed on 992
validate_surface: panic !worker->surfaces[surface_id].context.canvas
2012-08-29 21:05:25.628+0000: shutting down
Comment 1 Steve Tyler 2012-10-01 04:04:22 EDT
(In reply to comment #0)
...
> I cannot report this with abrt, because of this error:
...

I had the same problem and filed this bug against abrt:
Bug 861844 - Backtrace parsing failed for . ... 11:0: "Thread" header expected
Comment 2 Cole Robinson 2012-10-05 09:57:13 EDT
Looks like that code is in spice, reassigning for further triage.
Comment 3 Fedora Admin XMLRPC Client 2012-10-15 02:12:48 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 David Jaša 2013-01-04 05:40:50 EST
this line:

> validate_surface: panic !worker->surfaces[surface_id].context.canvas

suggests that this is the same as RHEL bug 824384, fixed in spice-0.12 that is included in Fedora 18 - so this could be closed as NEXTRELEASE or UPSTREAM in my opinion.
Comment 5 David Jaša 2013-05-03 04:47:15 EDT
James, Steve, could you retest on F18 to verify if the problem is indeed gone, please?

Thank you very much.
Comment 6 Jerry James 2013-05-03 10:00:26 EDT
I have used the virt-manager + spice framework heavily on F18 for the last few months, and have not encountered this problem.  Thanks!
Comment 7 David Jaša 2013-05-03 10:03:47 EDT
Thank you for testing!