Bug 853159

Summary: virt-rescue in Fedora 18 is completely broken
Product: [Community] Virtualization Tools Reporter: Richard W.M. Jones <rjones>
Component: libguestfsAssignee: Richard W.M. Jones <rjones>
Status: CLOSED UPSTREAM QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: dyasny, mbooth
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-04 11:52:55 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Richard W.M. Jones 2012-08-30 11:52:33 EDT
Description of problem:

$ virt-rescue -v --scratch
libguestfs: [00000ms] febootstrap-supermin-helper --verbose -f checksum '/usr/lib64/guestfs/supermin.d' x86_64
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00000ms] inputs[0] = /usr/lib64/guestfs/supermin.d
checking modpath /lib/modules/3.6.0-0.rc2.git2.1.fc18.x86_64 is a directory
picked vmlinuz-3.6.0-0.rc2.git2.1.fc18.x86_64 because modpath /lib/modules/3.6.0-0.rc2.git2.1.fc18.x86_64 exists
checking modpath /lib/modules/3.6.0-0.rc1.git6.1.fc18.x86_64 is a directory
picked vmlinuz-3.6.0-0.rc1.git6.1.fc18.x86_64 because modpath /lib/modules/3.6.0-0.rc1.git6.1.fc18.x86_64 exists
checking modpath /lib/modules/3.5.0-0.rc3.git0.4.bz835019.fc18.x86_64 is a directory
picked vmlinuz-3.5.0-0.rc3.git0.4.bz835019.fc18.x86_64 because modpath /lib/modules/3.5.0-0.rc3.git0.4.bz835019.fc18.x86_64 exists
supermin helper [00001ms] finished creating kernel
supermin helper [00001ms] visiting /usr/lib64/guestfs/supermin.d
supermin helper [00002ms] visiting /usr/lib64/guestfs/supermin.d/base.img
supermin helper [00002ms] visiting /usr/lib64/guestfs/supermin.d/daemon.img
supermin helper [00002ms] visiting /usr/lib64/guestfs/supermin.d/hostfiles
supermin helper [00173ms] visiting /usr/lib64/guestfs/supermin.d/init.img
supermin helper [00174ms] adding kernel modules
supermin helper [00406ms] finished creating appliance
libguestfs: [00430ms] begin testing qemu features
libguestfs: [00671ms] finished testing qemu features
[00680ms] /usr/bin/qemu-kvm \
    -global virtio-blk-pci.scsi=off \
    -nodefconfig \
    -nodefaults \
    -nographic \
    -device virtio-scsi-pci,id=scsi \
    -drive file=/var/tmp/rescueMLjQUu,cache=none,format=raw,id=hd0,if=none \
    -device scsi-hd,drive=hd0 \
    -drive file=/var/tmp/.guestfs-500/root.10688,snapshot=on,id=appliance,if=none,cache=unsafe \
    -device scsi-hd,drive=appliance \
    -machine accel=kvm:tcg \
    -m 500 \
    -no-reboot \
    -no-hpet \
    -device virtio-serial \
    -serial stdio \
    -device sga \
    -chardev socket,path=/tmp/libguestfsR5FbQa/guestfsd.sock,id=channel0 \
    -device virtserialport,chardev=channel0,name=org.libguestfs.channel.0 \
   libguestfs:  -kernel accept_from_daemon: 0x240cb70 g->state = 1/var/tmp/.guestfs-500/kernel.10688 \
   
 -initrd /var/tmp/.guestfs-500/initrd.10688 \
    -append 'panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm guestfs_rescue=1'libguestfs: child_cleanup: 0x240cb70: child process died
libguestfs: sending SIGTERM to process 10699
libguestfs: closing guestfs handle 0x240cb70 (state 0)


Version-Release number of selected component (if applicable):

libguestfs-tools-c-1.19.32-1.fc18.x86_64

How reproducible:

100%
Comment 1 Richard W.M. Jones 2012-09-04 08:17:37 EDT
git bisect points to:

ec8e3b6cad170d08ac18b580792dfb137eb171dc is the first bad commit
commit ec8e3b6cad170d08ac18b580792dfb137eb171dc
Author: Richard W.M. Jones <rjones@redhat.com>
Date:   Fri Jul 20 14:24:10 2012 +0100

    launch: Abstract attach method operations.
    
    g->attach_ops points to a structure which contains the
    operations supported by each attach method backend
    (ie. appliance, unix, etc.).

:040000 040000 a2e30ec3b15f9a3614b934b7db762acb48a655a9 fa9dc4a8b5679de5f96ea442e22e29c2ea0bcd46 M	src

Obviously this change, which was supposed to be code motion,
broke things somewhere.
Comment 2 Richard W.M. Jones 2012-09-04 11:52:55 EDT
Fixed in libguestfs 1.19.39.