Bug 854159

Summary: Network spoke status in hub is not updated automatically after cable plugged/unplugged
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: anacondaAssignee: Radek Vykydal <rvykydal>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, awilliam, g.kaviyarasu, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: anaconda-18.28-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-23 10:18:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kamil Páral 2012-09-04 08:44:28 UTC
Description of problem:
If I don't have ethernet cable connected, the Network spoke says "not connected" on the main hub screen. If I plug in the cable, nothing happens. I have to open the Network spoke and close it, and then it finally says "connected". The same thing applies for cable unplug - it says "connected" even when I unplug the cable. Only after I open the spoke and close it again, it finally displays "not connected" on the hub screen.

Version-Release number of selected component (if applicable):
F18 Alpha TC5
anaconda 18.6.4

How reproducible:
always

Steps to Reproduce:
1. boot anaconda without network cable
2. see "not connected" on the hub screen
3. connect cable
4. see that hub screen is not updated

Comment 1 Adam Williamson 2012-11-23 01:27:59 UTC
18.28 is stable. Kamil, can you confirm this is working in 18.28+? If so, it can be closed.

Comment 2 Kamil Páral 2012-11-23 10:18:36 UTC
Verified fixed in anaconda 18.29.2.