This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 854323

Summary: [abrt]: WARNING: at drivers/gpu/drm/i915/i915_drv.c:440 __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]()
Product: [Fedora] Fedora Reporter: dewang.accounts
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: ademar111190, ajax, andrew.stiegmann, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:c7222309639c892c87d7f44a2c1fbf19c24ae6ee
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-04 16:35:57 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description dewang.accounts 2012-09-04 12:04:51 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.4.9-2.fc16.x86_64 root=UUID=ce45cf29-7ba0-44d4-bfc4-edf9d031818e ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb KEYTABLE=uk rd.luks=0 LANG=en_US.UTF-8

backtrace:
:WARNING: at drivers/gpu/drm/i915/i915_drv.c:440 __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]()
:Hardware name: 42844DG
:Modules linked in: usb_storage tcp_lp fuse nfs fscache auth_rpcgss nfs_acl lockd rfcomm bnep nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 ip6table_filter nf_defrag_ipv4 ip6_tables xt_state nf_conntrack binfmt_misc sunrpc snd_hda_codec_conexant snd_hda_intel snd_hda_codec btusb bluetooth snd_hwdep arc4 snd_seq snd_seq_device tpm_tis i2c_i801 tpm snd_pcm iwlwifi uvcvideo videobuf2_core videodev media snd_timer snd_page_alloc videobuf2_vmalloc iTCO_wdt iTCO_vendor_support cdc_ncm usbnet mii coretemp mac80211 cfg80211 e1000e thinkpad_acpi tpm_bios videobuf2_memops cdc_wdm cdc_acm microcode snd rfkill soundcore joydev uinput crc32c_intel ghash_clmulni_intel hid_logitech_dj sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t nouveau ttm i915 drm_kms_helper drm i2c_algo_bit mxm_wmi i2c_core video wmi [last unloaded: scsi_wait_scan]
:Pid: 1242, comm: Xorg Tainted: G        W    3.4.9-2.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8105808f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff810580ea>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa00d394e>] __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]
: [<ffffffffa00d40a2>] i915_write32+0x82/0xe0 [i915]
: [<ffffffffa0111951>] ring_write_tail+0x21/0x30 [i915]
: [<ffffffffa011335f>] blt_ring_flush+0x9f/0xb0 [i915]
: [<ffffffffa00ec586>] i915_gem_do_execbuffer+0x1446/0x1610 [i915]
: [<ffffffffa00ecc4e>] i915_gem_execbuffer2+0xae/0x290 [i915]
: [<ffffffffa002e3cc>] drm_ioctl+0x47c/0x540 [drm]
: [<ffffffffa00ecba0>] ? i915_gem_execbuffer+0x450/0x450 [i915]
: [<ffffffff811843d9>] ? do_readv_writev+0x189/0x1d0
: [<ffffffff81195318>] do_vfs_ioctl+0x98/0x550
: [<ffffffff81195861>] sys_ioctl+0x91/0xa0
: [<ffffffff81605d69>] system_call_fastpath+0x16/0x1b
Comment 1 Adam Jackson 2012-09-11 15:01:36 EDT
*** Bug 854378 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Stiegmann 2012-09-28 23:05:49 EDT
Also happens if Xorg is not tainted.

from my machine:
[25655.634531] WARNING: at drivers/gpu/drm/i915/i915_drv.c:527 __gen6_gt_wait_for_fifo+0x89/0x90 [i915]()
...
[25655.634571] Pid: 945, comm: Xorg Not tainted 3.5.4-1.fc17.x86_64 #1
[25655.634572] Call Trace:
[25655.634578]  [<ffffffff8105867f>] warn_slowpath_common+0x7f/0xc0
[25655.634581]  [<ffffffff810586da>] warn_slowpath_null+0x1a/0x20
[25655.634603]  [<ffffffffa006fa19>] __gen6_gt_wait_for_fifo+0x89/0x90 [i915]
...
Comment 3 Adam Jackson 2013-01-04 16:35:57 EST

*** This bug has been marked as a duplicate of bug 772364 ***