Bug 855470 (lxdm.preset)

Summary: lxdm should ship a systemd preset to ensure it's enabled after install
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: lxdmAssignee: Christoph Wickert <cwickert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: cwickert, kparal
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-18 16:01:53 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 752664, 850775    

Description Adam Williamson 2012-09-07 18:27:34 EDT
As per https://bugzilla.redhat.com/show_bug.cgi?id=850775 , all DMs need to ship systemd presets in F18+ to ensure they get enabled post-install. Filing this bug so it can be nominated as NTH to get the fixed lxdm into the Alpha.
Comment 1 Adam Williamson 2012-09-10 14:10:06 EDT
Discussed at 2012-09-10 QA meeting, acting as an NTH review meeting. Accepted as NTH as it's a blocker for a non-blocking desktop.
Comment 2 Fedora Update System 2012-09-10 14:56:03 EDT
lxdm-0.4.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-4.fc18
Comment 3 Fedora Update System 2012-09-11 15:11:10 EDT
Package lxdm-0.4.1-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxdm-0.4.1-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13800/lxdm-0.4.1-4.fc18
then log in and leave karma (feedback).
Comment 4 Jens Petersen 2012-09-13 23:33:28 EDT
LXDE live is working but not "yum install lxdm", so moving back to assigned.

* Fri Sep 07 2012 Adam Williamson <awilliam@redhat.com> - 0.4.1-4
- ship a systemd preset for lxdm (#855470)
- add After: livesys-late.service to the service file, testing of other
  DMs indicated this is needed for lives

According to Lennart in bug 850775, preset should not be relative
to livesys-late.
Comment 5 Adam Williamson 2012-09-17 20:07:25 EDT
OK. That should be filed separately though. It's not this bug. Nor is the 'yum' case. I'm not sure that's actually intended to work as you think it is. You'd best check with Lennart whether you should file it as a bug or whether it's intended. But it's not this bug.
Comment 6 Fedora Update System 2012-09-18 16:01:53 EDT
lxdm-0.4.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.