Bug 857802

Summary: perl-Tk missing /usr/bin/widget
Product: [Fedora] Fedora Reporter: wuz73
Component: perl-TkAssignee: Xavier Bachelot <xavier>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 29CC: andreas.bierfert, perl-devel, tremble, xavier
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-03 13:44:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description wuz73 2012-09-17 04:34:23 UTC
Description of problem:
/usr/bin/widget is a very useful program to demo Perl-Tk widgets. However, it has been missing in perl-Tk-804.028-xxx

Version-Release number of selected component (if applicable):
perl-Tk-804.028-12.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum install perl-Tk
2. widget

Actual results:
bash: widget: command not found

Expected results:
start widget

Additional info:
I found /usr/bin/widget in perl-Tk-804.028-2.el6.rf.x86_64.rpm, but it's not on 6.3.

Comment 1 Xavier Bachelot 2018-08-02 15:04:37 UTC
I'm not sure why /usr/bin/widget is specifically excluded. Maybe there is a reason I'm missing. This is like that since initial import (014fee7), so reassigning to Fedora Rawhide, as it has the same issue.

Comment 2 Xavier Bachelot 2018-08-02 15:13:17 UTC
widget is actually installed in the doc directory.
/usr/share/doc/perl-Tk-804.028/widget

Comment 3 Jan Kurik 2018-08-14 10:58:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 Xavier Bachelot 2018-10-03 13:44:33 UTC
Haven't heard from the reporter, which is not exactly a surprise given this bug is very old.
Closing as not a bug as the requested command is actually provided by the package, although not at the place the reporter expected it to be.