Bug 8582

Summary: HD access error then setup hangs
Product: [Retired] Red Hat Linux Reporter: Jack Botner <botner>
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-10 03:31:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jack Botner 2000-01-18 21:57:10 UTC
I am attempting to upgrade a Red Hat Linux 5.1 installation with 6.1,
using the new graphical setup program. The PC is an Intel P233-MMX.
After "Upgrade" is selected, the message is displayed:

Error mounting ext2 filesystem on hda1: invalid argument

Then OK is pressed the program says "searching for Red Hat installations"
and hangs.

It may be relevant that the current Red Hat 5.1 is installed in hdb1 and
the swap partition is in hdb2.

Thank You,
Jack Botner botner@yesic.com

Comment 1 Jack Botner 2000-01-24 22:51:59 UTC
The same error occurs with the text installation program.

Comment 2 Jay Turner 2000-02-10 03:31:59 UTC
My guess is that you have a NTFS partition on /dev/hda1.  There is a known bug
in the 6.1 installer which caused it to try and mount NTFS partitions as ext2
partitions.  Of course, this does not work and the installer crashes out with
the message that you quoted.  If this is the case (you have a NTFS partition)
then the problem is fixed when using the errata boot images available from
updates.redhat.com as well as mirrors.  Please reopen this bug if you continue
to have problems.