Bug 85951

Summary: link gives error on bind mount
Product: [Retired] Red Hat Linux Reporter: Neal D. Becker <nbecker>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-30 15:40:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Neal D. Becker 2003-03-11 13:54:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
link("/home/nbecker/RPM/RPMS/i386/boost-jam-3.1.3-1.i386.rpm", "/var/ftp/pub/rh8.0/boost-jam-3.1.3-1.i386.rpm") = -1 EXDEV (Invalid cross-device link)

/disk1/nbecker on /home/nbecker type none (rw,bind)

It isn't a cross device link.  /home/nbecker is a bind mount.  /disk1/nbecker and /var/ftp are on the same device.

Linking /disk1/nbecker to /var/ftp works OK.

The semantics of a link on a bind mount should be the same as if there was no bind mount.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ln
2.
3.
    

Additional info:

Comment 1 Bugzilla owner 2004-09-30 15:40:38 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/