Bug 860927

Summary: [Drupal]Fail to import rows which title is longer than 128 characters.
Product: [Community] Publican Reporter: zhaiyu <yzhai>
Component: publicanAssignee: Hao Chang Yu <hyu>
Status: CLOSED CURRENTRELEASE QA Contact: Ruediger Landmann <rlandman>
Severity: high Docs Contact:
Priority: high    
Version: 3.0CC: hyu, jzhao, mjia, mshao, rglasz, rlandman, sbaird
Target Milestone: 3.0   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 3.0.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-30 23:10:59 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 863927    
Bug Blocks:    

Description zhaiyu 2012-09-27 02:23:15 EDT
Description of problem:
As summary, when import the drupal book generated by publican 3.1, the error infos on Drupal show like "path cannot be longer than <em>128</em> characters but is currently <em>129</em> characters long.,"0","2.2.5.3.".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create drupal book with publican 3.1.
2.Import the drupal book.
3.Check the import result.
  
Actual results:
As Description.

Expected results:


Additional info:
Comment 2 zhaiyu 2012-09-28 02:02:10 EDT
Verified on version publican-3.1-0.el6eng.t4.noarch.rpm:

After rebuild drupal-book with updated publican, the fail errors still have.

The error shows:

Input error: <em>2.2.3. Installing on Ubuntu and Debian</em> is not allowed for <em>Parent item</em> (not a book page in <em>OpenShift 2.0 Getting_Started_Guide</em>).,"0","2.2.3.4.
Comment 4 Jin Zhao 2012-09-28 11:58:32 EDT
Verify publican-3.1-0.el6eng.t5 -> FAIL

The issue is existing when the first time import
Comment 5 zhaiyu 2012-09-28 23:29:01 EDT
To avoid this issue, now build the drupal book as follows:

1. Run the command to build drupal book first time
   $publican build --langs en-US --formats=drupal-book
2. Clean the built drupal book with the command
   $publican clean
3. Rebuild the drupal book as Step 1
   $publican build --lans en-US --formats=drupal-book
4. Copy the /tmp/en-US/drupal-book/****.cvs to directory of drupal server
   $cp ****.cvs /opt/***/drupal-6/sites/default/files/imports/
   $cp -a en-US/ /opt/***/drupal-6/sites/default/files/
5. Import the drupal on Drupal Server
Comment 6 Hao Chang Yu 2012-09-29 01:01:55 EDT
this is because the updated xml files with the unique ids don't get copied to the tmp/ directory in te first time the publican build is run. I wll fix this.
Comment 7 matt jia 2012-10-02 00:39:05 EDT
(In reply to comment #5)
> To avoid this issue, now build the drupal book as follows:
> 
> 1. Run the command to build drupal book first time
>    $publican build --langs en-US --formats=drupal-book
> 2. Clean the built drupal book with the command
>    $publican clean
> 3. Rebuild the drupal book as Step 1
>    $publican build --lans en-US --formats=drupal-book
> 4. Copy the /tmp/en-US/drupal-book/****.cvs to directory of drupal server
>    $cp ****.cvs /opt/***/drupal-6/sites/default/files/imports/
>    $cp -a en-US/ /opt/***/drupal-6/sites/default/files/
> 5. Import the drupal on Drupal Server

Hi zhaiyu,

Follow above steps and cannot reproduct the bug.

I have run several import testings without any issue.

So the bug should be fixed in publican-3.1-0.el6eng.t6. Would you please verify it again ?

Cheers ,Matt Jia
Comment 8 zhaiyu 2012-10-07 21:47:07 EDT
(In reply to comment #7)
> (In reply to comment #5)
> > To avoid this issue, now build the drupal book as follows:
> > 
> > 1. Run the command to build drupal book first time
> >    $publican build --langs en-US --formats=drupal-book
> > 2. Clean the built drupal book with the command
> >    $publican clean
> > 3. Rebuild the drupal book as Step 1
> >    $publican build --lans en-US --formats=drupal-book
> > 4. Copy the /tmp/en-US/drupal-book/****.cvs to directory of drupal server
> >    $cp ****.cvs /opt/***/drupal-6/sites/default/files/imports/
> >    $cp -a en-US/ /opt/***/drupal-6/sites/default/files/
> > 5. Import the drupal on Drupal Server
> 
> Hi zhaiyu,
> 
> Follow above steps and cannot reproduct the bug.
> 
> I have run several import testings without any issue.
> 
> So the bug should be fixed in publican-3.1-0.el6eng.t6. Would you please
> verify it again ?
> 
> Cheers ,Matt Jia

The bug could be reproduced in publican-3.1-0.el6eng.t5 in my local, so I will verify the bug in publican-3.1-0.el6eng.t6.

Thanks
Zhai Yu
Comment 9 Hao Chang Yu 2012-10-07 22:45:36 EDT
Hi Zhai Yu

Please test package publican-3.1-0.el6eng.t7 instead.It is the latest one.

Thanks

Regards
Hao
Comment 10 zhaiyu 2012-10-08 01:20:30 EDT
Because the publican-doc-3.1-0.el6eng.t7 rpm is broken, the drupal book cannot be produced in build command. The block bug is 863927 for publican-doc-3.1-0.el6eng.t7.
Comment 11 zhaiyu 2012-10-08 04:33:25 EDT
Verified on publican-doc-3.1-0.el6eng.t8, the import issue has been fixed.