Bug 861646

Summary: Sporadic GPU Lockups when Fast User Switching
Product: [Fedora] Fedora Reporter: Adam Joseph Cook <acook>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: NEW --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: acook, airlied, ajax, awilliam, bskeggs, dichlofos-mv, mdomonko, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: RejectedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Pictures of corrupted display and messages when fast user switching
none
Output of dmesg with kernal boot parameter 'drm.debug-14' set
none
/var/log/messages piece related to failure none

Description Adam Joseph Cook 2012-09-29 12:53:04 EDT
Created attachment 619137 [details]
Pictures of corrupted display and messages when fast user switching

Description of problem:
Tested for Fedora 18 Nouveau Test Day

At various times (it seems to depend on how long the user in logged in with the more time, the worse), X locks up and corrupts the display after attempting to perform a fast user switch. The computer is not recoverable in this state and must be hard reset. The mouse cursor will not move. See the pictures attached for the effects of this issue.

This issue is very hard to catch and occurs without warning. After the first GPU lockup noted here, fast user switching worked several times, back and forth, without issue. Logs will be appended to this bug when available.

I actually had to hard reset several times as after the initial GPU lockup, the system had additional lockups after reboot before the GDM login screen was presented.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.1-6.fc18.x86_64
gnome-shell-3.6.0-1.fc18.x86_64

How reproducible:


Steps to Reproduce:
1. Logon to account.
2. Fast user switch (via clicking on the account name in the upper-right of the GNOME desktop -> Switch User)
3. Recieve corrupted display, GPU lockup and locked up system.
4. Hard reset system.
  
Actual results:
Sporadic GPU lockups sometimes. Other times, there are no issues.

Expected results:
Successful fast user switching without GPU and system lockups.

Additional info:

* Smolt Profile:

General
=================================
UUID: 72c98b9a-af7d-4fec-bdd9-32b96ccc9fd9
OS: Fedora release 18 (Spherical Cow)
Default run level: Unknown
Language: Unknown
Platform: x86_64
BogoMIPS: 5424.96
CPU Vendor: AuthenticAMD
CPU Model: AMD Athlon(tm) II X2 215 Processor
CPU Stepping: 2
CPU Family: 16
CPU Model Num: 6
Number of CPUs: 2
CPU Speed: 2700
System Memory: 3682
System Swap: 3695
Vendor: HP-Pavilion
System: BK149AA-ABA s5414y 
Form factor: Desktop
Kernel: 3.6.0-0.rc7.git1.4.fc18.x86_64
SELinux Enabled: 1
SELinux Policy: targeted
SELinux Enforce: Enforcing
MythTV Remote: Unknown
MythTV Role: Unknown
MythTV Theme: Unknown
MythTV Plugin: 
MythTV Tuner: -1


Devices
=================================
(4318:1014:4156:10860) pci, sata_nv, STORAGE, MCP61 SATA Controller
(4318:1014:4156:10860) pci, sata_nv, STORAGE, MCP61 SATA Controller
(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
(4318:976:4156:10860) pci, nouveau, VIDEO, C61 [GeForce 6150SE nForce 430]
(4318:1000:4156:10860) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
(4318:1009:4156:10860) pci, ohci_hcd, USB, MCP61 USB 1.1 Controller
(4318:1010:4156:10860) pci, ehci_hcd, USB, MCP61 USB 2.0 Controller
(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
(4318:1001:4156:10860) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
(4318:1011:4156:10860) pci, None, PCI/PCI, MCP61 PCI bridge
(4318:1007:4156:10860) pci, forcedeth, BRIDGE, MCP61 Ethernet
(4318:1001:4156:10860) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
(4318:1002:4156:10860) pci, None, RAM, MCP61 Memory Controller
(4318:1008:4156:10860) pci, snd_hda_intel, MULTIMEDIA, MCP61 High Definition Audio
(4318:1013:4156:10860) pci, None, RAM, MCP61 Memory Controller
(4318:1003:4156:10860) pci, nForce2_smbus, SERIAL, MCP61 SMBus
(4318:992:4156:10860) pci, None, PCI/ISA, MCP61 LPC Bridge


Filesystem Information
=================================
device mtpt type bsize frsize blocks bfree bavail file ffree favail
-------------------------------------------------------------------
/dev/sdb3 / ext4 4096 4096 12901535 11015738 10360378 3276800 3036473 3036473
/dev/sdb1 /boot ext4 1024 1024 495844 392932 367332 128016 127660 127660
/dev/sdb5 /home ext4 4096 4096 226399232 226178109 214677681 57507840 57505303 57505303
Comment 1 Adam Joseph Cook 2012-09-29 13:24:51 EDT
Created attachment 619143 [details]
Output of dmesg with kernal boot parameter 'drm.debug-14' set
Comment 2 Adam Joseph Cook 2012-09-29 13:26:04 EDT
This may be a more general nouveau issue than just during user switching. I just had X hang after rebooting the computer after about 1 hour of uptime. My dmesg output is now attached.

It is an odd issue because after X hangs, I cannot just reboot to clear this issue as X crashes again upon reboot (apparently, no matter how many times I reboot in succession). Only when I shutdown the system (power-off) can I reboot into the GDM.
Comment 3 Adam Williamson 2012-10-04 14:02:42 EDT
Discussed at 2012-10-04 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-04/f18-beta-blocker-review-2.1.2012-10-04-16.00.log.txt . As this looks like a single-system X issue, we reject it as a blocker by established precedent (X bugs that affect only a single system or small range of systems are not considered to be wide enough to be blockers; we don't have the development capacity to commit to fixing all such bugs).
Comment 4 Martin 2013-06-11 12:47:27 EDT
Adam Joseph Cook, are you able to reproduce it on latest Fedora 18 or 19?
Comment 5 Mikhail Veltishchev 2013-06-26 19:04:38 EDT
Almost same problem, occurs exactly on user switching. I have completely updated F18 installation with Gnome3 + Xfce.

As for hardware, it's an 8Gb RAM desktop with cheap nvidia-based card with passive cooling (I belive, this is not a hardware problem, as it worked perfectly on F16).

Attaching a piece of /var/log/messages output, maybe it helps.
Comment 6 Mikhail Veltishchev 2013-06-26 19:08:26 EDT
Created attachment 765835 [details]
/var/log/messages piece related to failure

F18 nouveau freeze (however, I managed to reboot the system using ssh from another workstation).
Comment 7 Martin 2013-06-27 05:26:00 EDT
Mikhail, could you try it with Fedora 19? It might be fixed in latest release.
Comment 8 Mikhail Veltishchev 2013-07-02 17:16:43 EDT
Maybe I give it a try after F19 final release. Btw, can I completely remove Gnome3 GDM, leaving only Xfce desktop manager and its user switcher?
Comment 9 Fedora End Of Life 2013-12-21 03:59:26 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Michal Domonkos 2014-06-17 10:23:26 EDT
It's not reproducible for me on F20 and NVIDIA Quadro 450.  There have been similar issues in the past that got fixed so there's a chance this one is gone for good, too.

Mikhail, have you reproduced such lockup since then?
Comment 12 Mikhail Veltishchev 2014-06-17 10:43:58 EDT
Well, my desktop now runs F20 using xorg-x11-drv-nouveau-1.0.9-2.fc20.x86_64, but I don't use fast user switching now (exactly because of this bug I decided to use lightweight lxde), so now I cannot easily test it, sorry.
Comment 13 Michal Domonkos 2014-06-17 10:59:45 EDT
Oh, sure, no problem.  Thank you for the quick reply, anyway!
Comment 14 Jan Kurik 2015-07-15 10:58:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23