Bug 861713

Summary: reporting fails when installed_packages is missing
Product: [Fedora] Fedora Reporter: Mikhail <mikhail.v.gavrilov>
Component: abrtAssignee: abrt <abrt-devel-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 18CC: abrt-devel-list, dvlasenk, iprikryl, jfilak, jmoskovc, kklic, mmilata, mtoman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-22 07:05:25 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mikhail 2012-09-30 03:39:43 EDT
Description of problem:

--- Running report_uReport ---
Locked './.lock'
Unlocked './.lock'
warning: 'uptime' is not an item in problem directory
warning: 'pkg_epoch' is not an item in problem directory
parse_release: version:'18' product:'Fedora'
post('https://retrace.fedoraproject.org/faf/reports/new/','{ "ureport_version": 1, "crash_thread": 0, "architecture": "i686", "executable": "\/usr\/bin\/file-roller", "reason": "Process \/usr\/bin\/file-roller was killed by signal 11 (SIGSEGV)", "type": "USERSPACE", "installed_package": { }, "related_packages": [ ], "os": { "name": "Fedora", "version": "18" }, "reporter": { "name": "ABRT", "version": "2.0.14" } }')
curl: About to connect() to retrace.fedoraproject.org port 443 (#0)

curl:   Trying 209.132.181.28...

curl: connected

curl: Connected to retrace.fedoraproject.org (209.132.181.28) port 443 (#0)

curl: Initializing NSS with certpath: sql:/etc/pki/nssdb

curl:   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none

curl: SSL connection using TLS_RSA_WITH_AES_256_CBC_SHA

curl: Server certificate:

curl: 	subject: CN=retrace.fedoraproject.org,OU=Information Systems,O=Red Hat Inc,L=Raleigh,ST=North Carolina,C=US,serialNumber=yAPlxlxAIynmUPcu9oHHthu6M9HG0I1P

curl: 	start date: Mar 14 05:22:57 2012 GMT

curl: 	expire date: May 16 07:55:58 2014 GMT

curl: 	common name: retrace.fedoraproject.org

curl: 	issuer: CN=GeoTrust SSL CA,O="GeoTrust, Inc.",C=US

curl sent header: 'POST /faf/reports/new/ HTTP/1.1
Host: retrace.fedoraproject.org
Accept: application/json
Connection: close
User-Agent: ABRT/2.0.14
Content-Length: 549
Expect: 100-continue
Content-Type: multipart/form-data; boundary=----------------------------4bfd5d6e1356

'
curl rcvd header: 'HTTP/1.1 100 Continue
'
curl sent data: '------------------------------4bfd5d6e1356
Content-Disposition: form-data; name="file"; filename="*buffer*"
Content-Type: application/json

{ "ureport_version": 1, "crash_thread": 0, "architecture": "i686", "executable": "\/usr\/bin\/file-roller", "reason": "Process \/usr\/bin\/file-roller was killed by signal 11 (SIGSEGV)", "type": "USERSPACE", "installed_package": { }, "related_packages": [ ], "os": { "name": "Fedora", "version": "18" }, "reporter": { "name": "ABRT", "version": "2.0.14" } }
------------------------------4bfd5d6e1356--
'
curl rcvd header: 'HTTP/1.1 400 BAD REQUEST
'
curl rcvd header: 'Date: Sun, 30 Sep 2012 07:32:29 GMT
'
curl rcvd header: 'Server: Apache/2.2.15 (Red Hat)
'
curl rcvd header: 'Vary: Cookie
'
curl rcvd header: 'ProxyTime: D=219610
'
curl rcvd header: 'ProxyServer: retrace01.qa.fedoraproject.org
'
curl rcvd header: 'Content-Length: 105
'
curl rcvd header: 'Connection: close
'
curl rcvd header: 'Content-Type: application/json
'
curl rcvd header: '
'
curl rcvd data: '{"error": "Validation failed: error validating 'installed_package': missing mandatory element 'release'"}'
curl: Closing connection #0

after curl_easy_perform: http code 400 body:'{"error": "Validation failed: error validating 'installed_package': missing mandatory element 'release'"}'
server side error: "Validation failed: error validating 'installed_package': missing mandatory element 'release'"
(exited with 1)
Comment 1 Jakub Filak 2012-10-22 07:05:25 EDT

*** This bug has been marked as a duplicate of bug 863500 ***