Bug 861858

Summary: qxl_blit: Program terminated with signal 11, Segmentation fault.
Product: [Fedora] Fedora Reporter: Steve Tyler <stephent98>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: amit.shah, berrange, cfergeau, crobinso, dwmw2, itamar, knoel, pbonzini, rjones, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-01 08:20:25 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
gdb log showing output from "t a a bt full"
none
backtrace generated by abrt none

Description Steve Tyler 2012-10-01 03:42:07 EDT
Created attachment 619641 [details]
gdb log showing output from "t a a bt full"

Description of problem:

$ gdb qemu-kvm ../ccpp-2012-09-30-21:09:00-2240/coredump
...
Core was generated by `qemu-kvm -m 2048 -hda f18-test-2.img -vga qxl'.
Program terminated with signal 11, Segmentation fault.
#0  __memcpy_sse2 () at ../sysdeps/x86_64/memcpy.S:202
202		movq	%rax,   (%rdi)

The attached backtrace was manually generated, because abrt couldn't parse the abrt-generated backtrace: Bug 861844.

Version-Release number of selected component (if applicable):

$ rpm -qa 'qemu*' | sort
qemu-common-1.0.1-1.fc17.x86_64
qemu-debuginfo-1.0.1-1.fc17.x86_64
qemu-img-1.0.1-1.fc17.x86_64
qemu-kvm-1.0.1-1.fc17.x86_64
qemu-system-x86-1.0.1-1.fc17.x86_64

$ uname -a
Linux walnut 3.5.4-2.fc17.x86_64 #1 SMP Wed Sep 26 21:58:50 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Twice now.

Steps to Reproduce:
1. $ qemu-kvm -m 2048 -hda f18-test-2.img -vga qxl
2.
3.
  
Actual results:
Crash.

Expected results:
No crash.

Additional info:

$ gdb qemu-kvm ../ccpp-2012-09-30-21:09:00-2240/coredump
GNU gdb (GDB) Fedora (7.4.50.20120120-50.fc17)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/qemu-kvm...Reading symbols from /usr/lib/debug/usr/bin/qemu-kvm.debug...done.
done.
[New LWP 2240]
[New LWP 2430]
[New LWP 2244]
[New LWP 2243]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `qemu-kvm -m 2048 -hda f18-test-2.img -vga qxl'.
Program terminated with signal 11, Segmentation fault.
#0  __memcpy_sse2 () at ../sysdeps/x86_64/memcpy.S:202
202		movq	%rax,   (%rdi)
Missing separate debuginfos, use: debuginfo-install celt051-0.5.1.3-4.fc17.x86_64 cryptopp-5.6.1-7.fc17.x86_64 dbus-libs-1.4.10-5.fc17.x86_64 flac-1.2.1-9.fc17.x86_64 gsm-1.0.13-6.fc17.x86_64 json-c-0.9-4.fc17.x86_64 keyutils-libs-1.5.5-2.fc17.x86_64 krb5-libs-1.10.2-6.fc17.x86_64 libICE-1.0.8-1.fc17.x86_64 libSM-1.2.1-1.fc17.x86_64 libXau-1.0.6-3.fc17.x86_64 libXcursor-1.1.13-1.fc17.x86_64 libXext-1.3.1-1.fc17.x86_64 libXfixes-5.0-2.fc17.x86_64 libXi-1.6.1-1.fc17.x86_64 libXrandr-1.3.1-3.fc17.x86_64 libXrender-0.9.7-1.fc17.x86_64 libXtst-1.2.0-3.fc17.x86_64 libasyncns-0.8-3.fc17.x86_64 libcom_err-1.42.3-2.fc17.x86_64 libdb-5.2.36-5.fc17.x86_64 libgcc-4.7.2-2.fc17.x86_64 libgcrypt-1.5.0-3.fc17.x86_64 libgpg-error-1.10-2.fc17.x86_64 libidn-1.24-1.fc17.x86_64 libogg-1.3.0-1.fc17.x86_64 libselinux-2.1.10-3.fc17.x86_64 libsndfile-1.0.25-2.fc17.x86_64 libssh2-1.4.1-2.fc17.x86_64 libstdc++-4.7.2-2.fc17.x86_64 libtasn1-2.12-1.fc17.x86_64 libvorbis-1.3.3-1.fc17.x86_64 libxcb-1.8.1-1.fc17.x86_64 nss-softokn-freebl-3.13.5-1.fc17.x86_64 openldap-2.4.32-2.fc17.x86_64 openssl-1.0.0j-2.fc17.x86_64 p11-kit-0.12-1.fc17.x86_64 pixman-0.24.4-2.fc17.x86_64 tcp_wrappers-libs-7.6-69.fc17.x86_64
(gdb) set logging on
Copying output to gdb.txt.
(gdb) t a a bt full
...
Comment 1 Steve Tyler 2012-10-01 10:17:11 EDT
Created attachment 619815 [details]
backtrace generated by abrt

The abrt-generated backtrace file has some additional info ...
Comment 2 Cole Robinson 2013-04-01 08:20:25 EDT
F17 qemu has been updated quite a bit since then, including some qxl patches. Please retest, and reopen if you can still reproduce on latest f17.