This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 862148

Summary: SELinux is preventing /usr/libexec/mission-control-5 from read, write access on the file user.
Product: [Fedora] Fedora Reporter: D. Charles Pyle <dcharlespyle>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:8bbb60b9bc0b5b7fb0e5716039d31ce538c73ff5da579a1e9c4c4972e59f8f80
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-02 04:47:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: type
none
File: hashmarkername none

Description D. Charles Pyle 2012-10-02 00:10:08 EDT
Description of problem:
I do not know what caused this error but I have been seeing alot of SELinux errors in this version of Fedora.

Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/mission-control-5 from read, write access on the file user.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mission-control-5 should be allowed read write access on the user file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:config_home_t:s0
:Target Objects                user [ file ]
:Source                        mission-control
:Source Path                   /usr/libexec/mission-control-5
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    2012-09-30 12:50:04 MDT
:Last Seen                     2012-10-01 16:37:27 MDT
:Local ID                      ff1ed8f4-66f1-4506-b8c3-03e309e75c5b
:
:Raw Audit Messages
:type=AVC msg=audit(1349131047.74:142): avc:  denied  { read write } for  pid=3465 comm="mission-control" name="user" dev="tmpfs" ino=132340 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:config_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349131047.74:142): avc:  denied  { open } for  pid=3465 comm="mission-control" path="/run/user/42/dconf/user" dev="tmpfs" ino=132340 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:config_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349131047.74:142): arch=x86_64 syscall=open success=yes exit=ECHILD a0=a782c0 a1=42 a2=180 a3=7fff51af6500 items=0 ppid=1 pid=3465 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=3 comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mission-control,xdm_dbusd_t,config_home_t,file,read,write
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t config_home_t:file { read write open };
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t config_home_t:file { read write open };
:
Comment 1 D. Charles Pyle 2012-10-02 00:10:11 EDT
Created attachment 620112 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:10:12 EDT
Created attachment 620113 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-02 04:47:47 EDT

*** This bug has been marked as a duplicate of bug 859782 ***