Bug 862776

Summary: /usr/bin/who returns no results - /var/run/utmp missing?
Product: [Fedora] Fedora Reporter: John Ellson <john.ellson>
Component: coreutilsAssignee: Ondrej Vasik <ovasik>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: kdudka, kzak, maxamillion, ovasik, p, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-19 03:33:46 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Ellson 2012-10-03 10:03:55 EDT
Description of problem:
/usr/bin/who returns no results  
Running under strace shows that it isn't finding /var/run/utmp.  There is no /var/run/utmp. 

"yum reinstall coreutils initscripts"  and "reboot" had no effect.

Version-Release number of selected component (if applicable):
coreutils-8.17-5.fc18.x86_64
initscripts-9.40-1.fc18.x86_64
kernel-3.6.0-0.rc7.git1.4.fc18.x86_64


How reproducible:


Steps to Reproduce:
1. who
2.
3.
  
Actual results:
no error message.  nothing

Expected results:
should list at least one logged in user

Additional info:
Fedora 18 system was created by yum upgrading from Fedora 17 live install.
Comment 1 John Ellson 2012-10-03 14:38:54 EDT
/usr/bin/who works in Fedora-18-Beta-TC1-x86_64-Live-Desktop
and also in initial install from that,
but then is broken after first updates.
Comment 2 John Ellson 2012-10-03 16:09:05 EDT
Apparently this is caused by the latest ststemd updates:
    systemd-193-1.fc18-x86_64

Starting from a Beta-TC1 Live image I had updated glibc and kernel
to lastest, rebooted, and /usr/bin/who still worked.

Then I did "yum update systemd*"  which brought in:

  qrencode-libs-3.3.1-4.fc18.x86_64
  libmicrohttpd-0.9.22-1.fc18.x86_64
  systemd-193-1.fc18.x86_64
  systemd-libs-193-1.fc18.x86_64
  systemd-sysv-193-1.fc18.x86_64
  libgudev1-193-1.fc18.x86_64

After rebooting again, /usr/bin/who had stopped working.
Comment 3 John Ellson 2012-10-03 17:15:20 EDT
Works again with systemd-194-1.fc18.x86_64  (from koji)
but I also had to switch selinux to permissive to be able to login at all.
Comment 4 John Ellson 2012-10-03 17:38:58 EDT
Updated (from koji) to:
     selinux-policy-3.11.1-29.fc19.noarch
     selinux-policy-devel-3.11.1-29.fc19.noarch
     selinux-policy-targeted-3.11.1-29.fc19.noarch

configured to "enforcing", rebooted

and /usr/bin/who still works.
Comment 5 Ondrej Vasik 2012-10-18 05:26:34 EDT
Thanks for report, based on the description and comments, this was caused by some missing selinux policy and it is solved now, right? Can we close it currentrelease then?
Comment 6 John Ellson 2012-10-18 12:32:16 EDT
Certainly, as far as I'm concerned.  Thanks