Bug 863309

Summary: guess OS type from iso name or url
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: berrange, crobinso, hbrock, jforbes, virt-maint
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-13 21:03:31 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jens Petersen 2012-10-05 00:06:43 EDT
Description of problem:
It would be nice if virt-manager tried to be a little clever
and guess OS type from the iso name or URL given to it.
If I am installing Fedora-*.iso there is a reasonable chance
that the OS is Linux/Fedora.

This RFE is kind of an extension of bug 736951 ...

Steps to Reproduce:
1. setup an install from a Fedora iso or url
  
Actual results:
1. virt-manager doesn't default OS type to Linux/Fedora

Expected results:
1. default to Linux
Comment 1 Daniel Berrange 2012-10-08 06:17:43 EDT
ISO filenames are somewhat unreliable, but it is possible to identify OS from the metadata fields in the ISO filesystem. libosinfo provides APIs & information required todo this.
Comment 2 Cole Robinson 2012-10-13 21:03:31 EDT
Thanks for the report, I'm just gonna fold this into the 'use libosinfo' report

*** This bug has been marked as a duplicate of bug 500320 ***
Comment 3 Jens Petersen 2012-10-18 08:27:39 EDT
Ok thanks.


(On a somewhat related note I was wondering also
why Linux is listed as the last choice?)
Comment 4 Cole Robinson 2012-10-24 15:24:28 EDT
(In reply to comment #3)
> Ok thanks.
> 
> 
> (On a somewhat related note I was wondering also
> why Linux is listed as the last choice?)

Yeah that's weird, I fixed it upstream:

http://git.fedorahosted.org/cgit/virt-manager.git/commit/?id=8f6b1f977b01a0b9057a4ade6813f41650887fc8