Bug 863374

Summary: nova boot fails because /dev/kvm is 0600 instead of 0666
Product: [Fedora] Fedora Reporter: Jan van Eldik <Jan.van.Eldik>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: akscram, alexander.sakhnov, amit.shah, apevec, apevec, asalkeld, berrange, bfilippov, breu, cfergeau, crobinso, dwmw2, itamar, Jan.van.Eldik, jonathansteffan, jose.castro.leon, knoel, markmc, matt_domsch, mlvov, pbonzini, p, rbryant, rjones, rkukura, sandro, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 860658 Environment:
Last Closed: 2012-10-27 19:07:52 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jan van Eldik 2012-10-05 05:30:16 EDT
+++ This bug was initially created as a clone of Bug #860658 +++

This exact same issues is present on F17 as well as F18, and thd
patch should work as well:

  $ cat /etc/fedora-release 
  Fedora release 17 (Beefy Miracle)
  $ ll /dev/kvm
  crw-------. 1 root kvm 10, 232 Oct  5 10:43 /dev/kvm
  $ sudo udevadm trigger --sysname-match=kvm
  $ ll /dev/kvm
  crw-rw-rw-. 1 root kvm 10, 232 Oct  5 11:27 /dev/kvm

Thanks, Jan
Comment 1 Cole Robinson 2012-10-07 15:13:53 EDT
Fix to F18 was here:

http://pkgs.fedoraproject.org/cgit/qemu.git/commit/?id=8cc727f1
Comment 2 Fedora Update System 2012-10-07 17:06:51 EDT
qemu-1.2.0-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.0-12.fc18
Comment 3 Pádraig Brady 2012-10-08 04:11:37 EDT
Hi Cole.
The point of this bug is to track the F17 status.
F18 is already handled by bug 860658

thanks.
Comment 4 Fedora Update System 2012-10-08 11:29:18 EDT
Package qemu-1.2.0-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.2.0-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15631/qemu-1.2.0-12.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-10-08 19:56:58 EDT
qemu-1.0.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qemu-1.0.1-2.fc17
Comment 6 Cole Robinson 2012-10-08 19:58:00 EDT
Yeah sorry that was a mistake, the F18 update description and bug list was meant for the F17 build.
Comment 7 Fedora Update System 2012-10-09 20:30:29 EDT
Package qemu-1.0.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.0.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15740/qemu-1.0.1-2.fc17
then log in and leave karma (feedback).
Comment 8 Jan van Eldik 2012-10-10 02:58:59 EDT
Package qemu-1.0.1-2.fc17 works for me, Karma given,

           thanks, Jan