Bug 863611

Summary: Fedora 18 couldn't mount Android device as disks
Product: [Fedora] Fedora Reporter: Mikhail <mikhail.v.gavrilov>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: fnord, gansalmon, itamar, jensk.maps, jonathan, kernel-maint, lenrynmq, lionghostshop, madhu.chinakonda, mail, mikhail.v.gavrilov, mschwage, wadehamptoniv
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-21 09:16:30 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
screenshot none

Description Mikhail 2012-10-06 00:17:54 EDT
Description of problem:
Fedora 18 couldn't mount Android device as disks

$ dmesg
[ 3287.125309] usb 2-2: new high-speed USB device number 5 using ehci_hcd
[ 3287.241792] usb 2-2: New USB device found, idVendor=18d1, idProduct=4e22
[ 3287.241804] usb 2-2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[ 3287.241812] usb 2-2: Product: Android
[ 3287.241817] usb 2-2: Manufacturer: Android
[ 3287.241822] usb 2-2: SerialNumber: 0123456789ABCDEF
[ 3287.250775] scsi6 : usb-storage 2-2:1.0
[ 3288.250976] scsi 6:0:0:0: Direct-Access     Android  Android          0000 PQ: 0 ANSI: 2
[ 3288.252126] scsi 6:0:0:1: Direct-Access     Android  Android          0000 PQ: 0 ANSI: 2
[ 3288.254746] sd 6:0:0:0: Attached scsi generic sg1 type 0
[ 3288.256729] sd 6:0:0:1: Attached scsi generic sg2 type 0
[ 3288.259044] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 3288.260412] sd 6:0:0:1: [sdc] Attached SCSI removable disk

$ uname -a
Linux localhost.localdomain 3.6.0-2.fc18.i686.PAE #1 SMP Tue Oct 2 22:45:34 UTC 2012 i686 i686 i386 GNU/Linux
Comment 1 Josh Boyer 2012-10-06 09:06:20 EDT
*** Bug 863612 has been marked as a duplicate of this bug. ***
Comment 2 Josh Boyer 2012-10-06 09:07:36 EDT
That all looks like it found and created two USB storage devices (sdb and sdc).  What isn't working?
Comment 3 Mikhail 2012-11-13 13:21:50 EST
Sorry I don't saw your question. I am attach screenshot that explain my problem. Yes I see that sdb and sdc is attached, but they are couldn't mounted.
Comment 4 Mikhail 2012-11-13 13:22:23 EST
Created attachment 644293 [details]
screenshot
Comment 5 Josh Boyer 2012-11-14 12:02:58 EST
From what I remember, Android devices often present their storage as MTP devices.  You might try installing mtpfs and seeing if you can access it through that.
Comment 6 lionghostshop 2013-02-19 07:50:53 EST
[leo@thinkpad-leo ~]$ mtpfs 
Listing raw device(s)
Device 0 (VID=04e8 and PID=685c) is a Samsung Galaxy models (MTP+ADB).
   Found 1 device(s):
   Samsung: Galaxy models (MTP+ADB) (04e8:685c) @ bus 2, dev 3
Attempting to connect device
Android device detected, assigning default bug flags
Comment 7 Sam Tuke 2013-03-08 04:13:17 EST
Same problem here:

[root@127 samtuke]# mtpfs
Listing raw device(s)
Device 0 (VID=04e8 and PID=685c) is a Samsung Galaxy models (MTP+ADB).
   Found 1 device(s):
   Samsung: Galaxy models (MTP+ADB) (04e8:685c) @ bus 1, dev 7
Attempting to connect device
libusb_detach_kernel_driver() failed, continuing anyway...: No such file or directory
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
Android device detected, assigning default bug flags
Error 1: Get Storage information failed.
Error 2: PTP Layer error 02fe: get_handles_recursively(): could not get object handles.
Error 2: Error 02fe: PTP: Protocol error, data expected
Listing File Information on Device with name: (NULL)
LIBMTP_Get_Storage() failed:-1
Comment 8 Dan Taylor 2013-04-23 20:21:27 EDT
Same problem, FC18 x86_64, tried mtpfs, then simple-mtpfs; samsung galaxy note 2 comes up as rhythmbox device, but doesn't show internal files, then phone unmounts itself saying it can't find appropriate software on the host system, referencing windows and mac software to fix the problem.
Comment 9 Michael Schwager 2013-05-15 15:58:19 EDT
Same problem with Google Nexus tablet on FC18 x86_64.  Here's what I got:

[root@rodin ~]# mtpfs 
Listing raw device(s)
Device 0 (VID=18d1 and PID=4ee1) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   18d1:4ee1 @ bus 1, dev 6
Attempting to connect device
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0


From dmesg:

[23002.761635] usb 1-1.2: new high-speed USB device number 6 using ehci_hcd
[23002.847181] usb 1-1.2: New USB device found, idVendor=18d1, idProduct=4ee1
[23002.847188] usb 1-1.2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[23002.847192] usb 1-1.2: Product: Nexus 10
[23002.847195] usb 1-1.2: Manufacturer: samsung
[23002.847197] usb 1-1.2: SerialNumber: R32CB04TECJ
[23404.166102] usb 1-1.2: usbfs: process 30066 (simple-mtpfs) did not claim interface 0 before use
[23404.238749] usb 1-1.2: reset high-speed USB device number 6 using ehci_hcd
[23404.329557] usb 1-1.2: usbfs: process 30066 (simple-mtpfs) did not claim interface 0 before use
[23617.667261] usb 1-1.2: reset high-speed USB device number 6 using ehci_hcd
Comment 10 Lenry 2013-05-17 18:09:52 EDT
Same problem here

dmesg
[ 1079.057646] usb 1-1.5: new high-speed USB device number 13 using ehci-pci
[ 1079.143901] usb 1-1.5: New USB device found, idVendor=1004, idProduct=61f9
[ 1079.143906] usb 1-1.5: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[ 1079.143909] usb 1-1.5: Product: LGE U2 USB Device
[ 1079.143912] usb 1-1.5: Manufacturer: LGE
[ 1079.143914] usb 1-1.5: SerialNumber: 2594000600000001015F0B560F018005

than mtpfs

Listing raw device(s)
Device 0 (VID=1004 and PID=61f9) is a LG Electronics Inc. V909 G-Slate.
   Found 1 device(s):
   LG Electronics Inc.: V909 G-Slate (1004:61f9) @ bus 1, dev 13
Attempting to connect device
libusb_detach_kernel_driver() failed, continuing anyway...: No such file or directory
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
inep: usb_get_endpoint_status(): No such device
outep: usb_get_endpoint_status(): No such device
usb_clear_halt() on IN endpoint: No such device
usb_clear_halt() on OUT endpoint: No such device
usb_clear_halt() on INTERRUPT endpoint: No such device
libusb_open() failed!: No such device
LIBMTP PANIC: Could not init USB on second attempt
Unable to open raw device 0

Fedora 18 x86_64 and LG Optimus L9 (P760) with Android 4.1.2
Comment 11 Wade Hampton 2013-08-17 15:53:25 EDT
I am having the same problem with an updated Fedora 18 and 
a Motorola Atrix HD.

Attempt to mount as MPT:

$ simple-mtpfs -o allow_other /media/android/
Device 0 (VID=22b8 and PID=710f) is a Motorola XT890/907 (MTP+?).
LIBMTP PANIC: Unable to find interface & endpoints of device


$ uname -a
Linux core6 3.10.6-100.fc18.x86_64 #1 SMP Mon Aug 12 15:51:00 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

It will allow mounting of the partition with the MotorolaDeviceManagerSetup.exe
on it (appears as a CD-ROM):

[  227.070745] usb 2-2: new high-speed USB device number 2 using ehci-pci
[  227.186531] usb 2-2: New USB device found, idVendor=22b8, idProduct=710f
[  227.186542] usb 2-2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[  227.186549] usb 2-2: Product: MB886
[  227.186555] usb 2-2: Manufacturer: motorola
[  227.186560] usb 2-2: SerialNumber: TA24909G97
[  227.302454] usb-storage 2-2:1.0: USB Mass Storage device detected
[  227.302625] scsi6 : usb-storage 2-2:1.0
[  227.302959] usbcore: registered new interface driver usb-storage
[  228.307178] scsi 6:0:0:0: CD-ROM            motorola MB886            0001 PQ: 0 ANSI: 2
[  228.311224] sr1: scsi-1 drive
[  228.311988] sr 6:0:0:0: Attached scsi CD-ROM sr1
[  228.312453] sr 6:0:0:0: Attached scsi generic sg3 type 5
[  236.698669] fuse init (API version 7.22)
[  236.734573] SELinux: initialized (dev fusectl, type fusectl), uses genfs_contexts
[  236.841439] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[  256.201700] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[  267.070353] ISO 9660 Extensions: Microsoft Joliet Level 1
[  267.127168] ISOFS: changing to secondary root
[  267.127803] SELinux: initialized (dev sr1, type iso9660), uses genfs_contexts
Comment 12 Justin M. Forbes 2013-10-18 17:10:36 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 13 lionghostshop 2013-10-19 03:10:51 EDT
It works in new kernel
Comment 14 Josh Boyer 2013-10-21 09:16:30 EDT
Thanks.
Comment 15 Wade Hampton 2013-10-27 15:30:34 EDT
Still an issue on my Fedora 18 computer.  I am now
upgrading to F19 so can't test on F18, but will re-test on F19.

$ uname -a
Linux core6 3.11.4-101.fc18.x86_64 #1 SMP Thu Oct 10 14:05:32 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ simple-mtpfs -l
Device 0 (VID=22b8 and PID=710f) is a Motorola XT890/907 (MTP+?).
1: MotorolaXT890/907 (MTP+?)

$ simple-mtpfs ./tmp
Device 0 (VID=22b8 and PID=710f) is a Motorola XT890/907 (MTP+?).
LIBMTP PANIC: Unable to find interface & endpoints of device