Bug 863683

Summary: SELinux is preventing /usr/bin/dbus-daemon from read, open access on the file /usr/libexec/mission-control-5.
Product: [Fedora] Fedora Reporter: Adam Joseph Cook <acook>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:559183d55c6f7f2a0491f2cfc31453cca14348aa3c644cf2a406fd19e5290766
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-08 05:56:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: type
none
File: hashmarkername none

Description Adam Joseph Cook 2012-10-06 11:41:38 EDT
Description of problem:
Logged in to GNOME desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/bin/dbus-daemon from read, open access on the file /usr/libexec/mission-control-5.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that dbus-daemon should be allowed read open access on the mission-control-5 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:telepathy_mission_control_exec_t
:                              :s0
:Target Objects                /usr/libexec/mission-control-5 [ file ]
:Source                        dbus-daemon
:Source Path                   /usr/bin/dbus-daemon
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           dbus-1.6.8-2.fc18.x86_64
:Target RPM Packages           telepathy-mission-control-5.14.0-1.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-06 10:36:39 CDT
:Last Seen                     2012-10-06 10:36:39 CDT
:Local ID                      6022d929-a6e4-455e-bb6c-09e2e3a4daff
:
:Raw Audit Messages
:type=AVC msg=audit(1349537799.281:135): avc:  denied  { read open } for  pid=984 comm="dbus-daemon" path="/usr/libexec/mission-control-5" dev="sdb3" ino=1982359 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:telepathy_mission_control_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349537799.281:135): arch=x86_64 syscall=execve success=no exit=EACCES a0=1fc26e0 a1=1fc11e0 a2=1fc2d10 a3=7fff187cf7e0 items=0 ppid=983 pid=984 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=1 comm=dbus-daemon exe=/usr/bin/dbus-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dbus-daemon,xdm_dbusd_t,telepathy_mission_control_exec_t,file,read,open
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:allow xdm_dbusd_t telepathy_mission_control_exec_t:file { read open };
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:allow xdm_dbusd_t telepathy_mission_control_exec_t:file { read open };
:
Comment 1 Adam Joseph Cook 2012-10-06 11:41:40 EDT
Created attachment 622749 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-06 11:41:42 EDT
Created attachment 622750 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 05:56:00 EDT

*** This bug has been marked as a duplicate of bug 859782 ***