Bug 863688

Summary: SELinux is preventing firewalld from 'read' accesses on the file /etc/hosts.
Product: [Fedora] Fedora Reporter: Adam Joseph Cook <acook>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dominick.grift, dwalsh, mgrepl, mikhail.v.gavrilov, mishu
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:894bec0c874e6ba81f9fff2e880a88f9b5ce9dccda36b03dedc5ffd622b92529
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-08 04:00:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: type
none
File: hashmarkername none

Description Adam Joseph Cook 2012-10-06 11:45:29 EDT
Description of problem:
Logged in to GNOME desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing firewalld from 'read' accesses on the file /etc/hosts.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that firewalld should be allowed read access on the hosts file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep firewalld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewalld_t:s0
:Target Context                system_u:object_r:net_conf_t:s0
:Target Objects                /etc/hosts [ file ]
:Source                        firewalld
:Source Path                   firewalld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           setup-2.8.57-1.fc18.noarch
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-10-06 00:42:08 CDT
:Last Seen                     2012-10-06 10:07:17 CDT
:Local ID                      a813186c-602d-45da-a6b0-665ef889cebe
:
:Raw Audit Messages
:type=AVC msg=audit(1349536037.420:16): avc:  denied  { read } for  pid=435 comm="firewalld" name="hosts" dev="sdb3" ino=1310747 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:net_conf_t:s0 tclass=file
:
:
:Hash: firewalld,firewalld_t,net_conf_t,file,read
:
:audit2allow
:
:#============= firewalld_t ==============
:allow firewalld_t net_conf_t:file read;
:
:audit2allow -R
:
:#============= firewalld_t ==============
:allow firewalld_t net_conf_t:file read;
:
Comment 1 Adam Joseph Cook 2012-10-06 11:45:32 EDT
Created attachment 622761 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-06 11:45:33 EDT
Created attachment 622762 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:00:19 EDT

*** This bug has been marked as a duplicate of bug 863687 ***