Bug 863804

Summary: [abrt]: WARNING: at fs/dcache.c:1375 d_set_d_op+0x7c/0xb0(): TAINTED G
Product: [Fedora] Fedora Reporter: pantherrdre
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: bugzilla.redhat.com, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:bea0cec3ae85cd7fafeb64ab496793d50557bcf9
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-08 09:00:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description pantherrdre 2012-10-07 10:46:55 EDT
Description of problem:
1. Started the Computer
2. I mounted a second Hard Disk /dev/hdb2 on /disk
3. I edited the /etc/fstab file to enable quotas on an ext3 file system.
4. I turned on qutoas using quotaon
5. I tried set the quota limit for /disk2 for my user (rambo) the file using edquota
6. I tried to check the quota limits using repquota -a; unfortunately the quota limits for rambo are not listed
7 I restarted the computer, hoping to have some success with the repquota.
8 I get the kernel error

The kernel problem confuses me though.  It seems to occur just after the initialization of the virtualbox
shared folder.  


Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.4-2.fc17.x86_64 root=/dev/mapper/vg_fedoralight-lv_root ro rd.md=0 rd.dm=0 SYSFONT=True KEYTABLE=de rd.lvm.lv=vg_fedoralight/lv_root rd.lvm.lv=vg_fedoralight/lv_swap rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.4-2.fc17.x86_64
kernel_tainted_long: Proprietary module has not been loaded.

backtrace:
:WARNING: at fs/dcache.c:1375 d_set_d_op+0x7c/0xb0()
:Hardware name: VirtualBox
:Modules linked in: vboxsf(O) vboxguest(O) nls_utf8 hfsplus hfs vfat fat fuse vboxvideo(O) drm nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE lockd sunrpc ip6table_mangle ip6t_REJECT bnep bluetooth nf_conntrack_ipv6 nf_defrag_ipv6 rfkill ip6table_filter ip6_tables iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack snd_intel8x0 snd_ac97_codec ac97_bus snd_seq snd_seq_device ppdev snd_pcm snd_page_alloc snd_timer snd soundcore parport_pc parport e1000 i2c_piix4 i2c_core microcode uinput [last unloaded: vboxguest]
:Pid: 9524, comm: mv Tainted: G           O 3.5.4-2.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff810586aa>] warn_slowpath_null+0x1a/0x20
: [<ffffffff8119c46c>] d_set_d_op+0x7c/0xb0
: [<ffffffffa013235b>] sf_instantiate.isra.1+0xcb/0x180 [vboxsf]
: [<ffffffffa01325bc>] sf_create_aux+0x1ac/0x250 [vboxsf]
: [<ffffffffa0132693>] sf_create+0x13/0x20 [vboxsf]
: [<ffffffff81193d84>] vfs_create+0xb4/0x110
: [<ffffffff811953dd>] do_last+0x7ad/0x9d0
: [<ffffffff8114d535>] ? handle_pte_fault+0x95/0xb10
: [<ffffffff8127e0ba>] ? selinux_file_alloc_security+0x4a/0x80
: [<ffffffff811974d6>] path_openat+0xd6/0x3f0
: [<ffffffff81197911>] do_filp_open+0x41/0xa0
: [<ffffffff811a38dd>] ? alloc_fd+0x4d/0x120
: [<ffffffff81187786>] do_sys_open+0xf6/0x1e0
: [<ffffffff810d36cc>] ? __audit_syscall_entry+0xcc/0x300
: [<ffffffff81187891>] sys_open+0x21/0x30
: [<ffffffff81614ee9>] system_call_fastpath+0x16/0x1b
Comment 1 pantherrdre 2012-10-07 11:00:02 EDT
I am not really sure as to why this problem occured.  This is the 4th time that I have received this error since I installed the latest Fedora 17 kernel.  I have not done anything special other than basic commands since I am new to linux.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Josh Boyer 2012-10-08 09:00:26 EDT
This is a bug in the vboxsf module.  Fedora doesn't provide that.
Comment 3 pantherrdre 2012-10-09 04:28:35 EDT
Ok, I will contact VirtualBox then.  Thanks anyway
Comment 4 Penelope Fudd 2012-10-12 13:37:29 EDT
I also got an error in vboxsf module; I was just starting to create a new file on a shared read-write folder using 'vi':

WARNING: at fs/dcache.c:1375 d_set_d_op+0x7c/0xb0()
Hardware name: VirtualBox
Modules linked in: vboxvideo(O) drm lockd sunrpc bnep bluetooth rfkill ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state ip6table_filter nf_conntrack ip6_tables snd_intel8x0 snd_ac97_codec ac97_bus snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd ppdev soundcore parport_pc parport i2c_piix4 i2c_core e1000 microcode vboxsf(O) vboxguest(O) uinput [last unloaded: scsi_wait_scan]
Pid: 1823, comm: vi Tainted: G           O 3.5.5-2.fc17.x86_64 #1
Call Trace:
 [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff810586aa>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8119c20c>] d_set_d_op+0x7c/0xb0
 [<ffffffffa005335b>] sf_instantiate.isra.1+0xcb/0x180 [vboxsf]
 [<ffffffffa00535bc>] sf_create_aux+0x1ac/0x250 [vboxsf]
 [<ffffffffa0053693>] sf_create+0x13/0x20 [vboxsf]
 [<ffffffff81193b24>] vfs_create+0xb4/0x110
 [<ffffffff8119517d>] do_last+0x7ad/0x9d0
 [<ffffffff81173476>] ? kfree+0xb6/0x160
 [<ffffffff8127de3a>] ? selinux_file_alloc_security+0x4a/0x80
 [<ffffffff81197276>] path_openat+0xd6/0x3f0
 [<ffffffff811730f1>] ? kmem_cache_alloc+0x71/0x160
 [<ffffffff811976b1>] do_filp_open+0x41/0xa0
 [<ffffffff811a367d>] ? alloc_fd+0x4d/0x120
 [<ffffffff81187526>] do_sys_open+0xf6/0x1e0
 [<ffffffff810d346c>] ? __audit_syscall_entry+0xcc/0x300
 [<ffffffff81187631>] sys_open+0x21/0x30
 [<ffffffff81614fa9>] system_call_fastpath+0x16/0x1b

I'm putting this here because it's the same backtrace but simpler to reproduce.  Perhaps the VirtualBox team can check this bug report.

I'm using Fedora17 on MacOSX 10.6.8 with Vbox 4.2.1 build 80871, and the shared folder is set to automount, readwrite, permanent.  The system is otherwise trouble-free, well, except for the sound system not working!  :-)