Bug 863886

Summary: anaconda does not install firstboot
Product: [Fedora] Fedora Reporter: Christoph Wickert <cwickert>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam, g.kaviyarasu, jonathan, kparal, robatino, satellitgo, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: anaconda-18.15-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-23 09:01:07 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 752660    
Attachments:
Description Flags
/var/log/anaconda/anaconda.packaging.log none

Description Christoph Wickert 2012-10-07 19:53:16 EDT
Description of problem:
Firstboot does not get installed even though it is in the comps group.

Version-Release number of selected component (if applicable):
Fedora 18 beta TC2

How reproducible:
always

Steps to Reproduce:
1. Select LXDE during install.
2. Reboot when finished.

Actual results:
LXDM shows up, but you cannot log in as no user was created.

# rpm -q firstboot
package firstboot is not installed.

Expected results:
firstboot

Additional info:
firstboot is in the lxde-desktop group and according to anaconda-ks.cfg, that group was installed.

I am proposing this as a blocker for beta because
- It violates an alpha release criterion: "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention."
- If prevents testing further release criteria like being able to play sound, open a browser etc.

We should think about another release criteria: "If a desktop environment was installed, a user must be created and this user must be able to successfully log in." If one does not unlock the root account, one ends up with a useless installation.
Comment 1 Chris Lumens 2012-10-08 10:02:37 EDT
Please attach /var/log/anaconda/anaconda.packaging.log from the installed system to this bug report.  Thanks.
Comment 2 Christoph Wickert 2012-10-08 12:28:52 EDT
Created attachment 623541 [details]
/var/log/anaconda/anaconda.packaging.log

Here you are.
Comment 3 Chris Lumens 2012-10-08 13:48:13 EDT
Oh, I see.  This is because we default to selecting the GNOME desktop group.  Then when you change environments, we first apply your selection and then apply the removal of the GNOME environment.  This means that firstboot gets marked for removal after it gets marked for adding.  Guess which one wins.
Comment 4 Christoph Wickert 2012-10-08 14:19:32 EDT
Yeah, I guessed that when looking at the log. I'm afraid we'll face the same problem with a lot more groups. if we follow this logic, the package selection will become completely unpredictable. How did anaconda resolve this in the past?
Comment 5 Chris Lumens 2012-10-08 14:38:27 EDT
The package selection and packaging backends were completely different in the past.  We just need to be a little less enthusiastic in our removals here.  Posting a patch to the list after this test finishes up.
Comment 6 Adam Williamson 2012-10-10 02:13:59 EDT
Christoph: we do in fact have a criterion to cover this already, it's right before the one you cited:

"In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account "

It's entirely natural to fall asleep halfway through reading that, but if you fight through it, it does require firstboot to run and be able to create a user account on the first boot after a graphical install. :)

+1 blocker.
Comment 7 Adam Williamson 2012-10-10 14:50:50 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Accepted as a blocker per criterion cited in comment #6 - this will affect KDE installs, so it affects a release-blocking desktop, so blocker.
Comment 8 Fedora Update System 2012-10-10 21:05:54 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18
Comment 9 Fedora Update System 2012-10-10 22:59:37 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-11 21:07:38 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 11 Kamil Páral 2012-10-15 09:52:18 EDT
This is fixed with F18 Beta TC4.
Comment 12 Fedora Update System 2012-10-16 23:10:47 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 13 Fedora Update System 2012-10-17 13:32:12 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 14 Adam Williamson 2012-10-17 18:54:09 EDT
back to VERIFIED. i should really file a bug with Luke that bodhi shouldn't change bugs from VERIFIED to ON_QA...
Comment 15 Fedora Update System 2012-10-17 22:39:28 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 16 Fedora Update System 2012-10-18 11:31:58 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-10-19 21:35:18 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 18 Fedora Update System 2012-10-19 23:53:10 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 19 Kamil Páral 2012-10-23 09:01:07 EDT
Fixed, anaconda stable, closing.