Bug 864148

Summary: SELinux is preventing /usr/bin/bash from 'write' accesses on the fifo_file /run/systemd/sessions/110.ref (deleted).
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:927f3a8d2a4e4c631786dcb6cbb3d6e99e0e95f9a5e110813ce7e4de49880b38
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-09 04:18:58 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: type
none
File: hashmarkername none

Description Nicolas Mailhot 2012-10-08 13:55:43 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.7.0-0.rc0.git2.4.fc19.x86_64

description:
:SELinux is preventing /usr/bin/bash from 'write' accesses on the fifo_file /run/systemd/sessions/110.ref (deleted).
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If vous souhaitez ignorer que bash tente d'obtenir l'accès write à 110.ref (deleted) fifo_file car vous pensez qu'il ne devrait pas nécessiter cet accès.
:Then vous devriez rapporter ceci en tant qu'anomalie.  
:Vous pouvez générer un module de stratégie local pour dontaudit cet accès.
:Do
:# grep /usr/bin/bash /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If vous pensez que bash devrait être autorisé à accéder write sur 110.ref (deleted) fifo_file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep prelink /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:prelink_cron_system_t:s0-s0:c0.c
:                              1023
:Target Context                system_u:object_r:systemd_logind_sessions_t:s0
:Target Objects                /run/systemd/sessions/110.ref (deleted) [
:                              fifo_file ]
:Source                        prelink
:Source Path                   /usr/bin/bash
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           bash-4.2.37-7.fc19.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.7.0-0.rc0.git2.4.fc19.x86_64 #1
:                              SMP Fri Oct 5 20:59:24 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-08 03:23:14 CEST
:Last Seen                     2012-10-08 03:23:14 CEST
:Local ID                      f03d1279-0a60-4fb0-bfe4-d8bcc085b351
:
:Raw Audit Messages
:type=AVC msg=audit(1349659394.818:8782): avc:  denied  { write } for  pid=7867 comm="prelink" path=2F72756E2F73797374656D642F73657373696F6E732F3131302E726566202864656C6574656429 dev="tmpfs" ino=2143403 scontext=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349659394.818:8782): arch=x86_64 syscall=execve success=yes exit=0 a0=23df6a0 a1=23e0e10 a2=23dff50 a3=8 items=0 ppid=7122 pid=7867 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=110 tty=(none) comm=prelink exe=/usr/bin/bash subj=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 key=(null)
:
:Hash: prelink,prelink_cron_system_t,systemd_logind_sessions_t,fifo_file,write
:
:audit2allow
:
:#============= prelink_cron_system_t ==============
:allow prelink_cron_system_t systemd_logind_sessions_t:fifo_file write;
:
:audit2allow -R
:
:#============= prelink_cron_system_t ==============
:allow prelink_cron_system_t systemd_logind_sessions_t:fifo_file write;
:
Comment 1 Nicolas Mailhot 2012-10-08 13:55:47 EDT
Created attachment 623610 [details]
File: type
Comment 2 Nicolas Mailhot 2012-10-08 13:55:50 EDT
Created attachment 623611 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-09 04:18:58 EDT

*** This bug has been marked as a duplicate of bug 864143 ***