Bug 86428

Summary: common widget rendering library
Product: [Retired] Red Hat Linux Reporter: Julien Olivier <julo42>
Component: gtk2-enginesAssignee: Owen Taylor <otaylor>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0Keywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-21 20:44:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Julien Olivier 2003-03-21 20:34:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
I thought of a way to ease the creation of common themes (such as Bluecurve) for
different toolkits:

-Create a library whose goal will be to return pixmaps for each type of widget.
Call it for example XStyle
-Create a theme engine for GTK which will dynamically load XStyle to get each
widget's pixmap.
-Create a style plugin for QT which will dynamically load XStyle to get each
widget's pixmap.
-Configure GNOME and KDE to use those styles by default.
-Port existing QT/GTK themes to make them "plugins" for the XStyle library and
integrate those themes into the theme managers of KDE and GNOME instead of the
old ones.
-Do the same for XUL, OpenOffice, Wine etc...
-Voila ! You have an unified theme engine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start a GTK app
2.Start a QT app
3.Change QT's theme or GTK's theme
    

Actual Results:  GTK theme doesn't match QT theme... neither doe OpenOffice or
Wine for example.

Expected Results:  One theme engine to rule them all !

Additional info:

Comment 1 Owen Taylor 2003-03-21 20:44:12 UTC
I'm not really sure that Red Hat bugzilla is the right place
for this bug. While the idea makes some sense, Red Hat bugzilla
is meant for tracking defects with Red Hat products and projects
that Red Hat developers are working on. 

(My personal guess is that a standardized pixmap theme format is 
probably more interesting than a common library, but perhaps
a common library is the best way to get widespread adoption of
a standardized format. There are some issues in that rendering
has to be somewhat specialized to the widget library ... e.g.,
for GTK+, just rendering to an X drawable wouldn't be acceptable
because GTK+ themes should work in Windows as well, where the
GDK levels calls are the same, but the X level calls aren't there.)