Bug 864392

Summary: fuseiso: does not work on ppc64
Product: [Fedora] Fedora Reporter: Florian Weimer <fweimer>
Component: fuseisoAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: tcallawa, zali
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnome-boxes-3.14.0-3.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040469 1148814 (view as bug list) Environment:
Last Closed: 2014-10-04 03:21:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1071880, 1148814, 861356, 1040469    
Attachments:
Description Flags
fuseiso-uchar.patch none

Description Florian Weimer 2012-10-09 10:31:15 UTC
Created attachment 624021 [details]
fuseiso-uchar.patch

Description of problem:

After fixing the endless loop in the command line parser (see patch), fuseiso still cannot mount any ISO images.

Version-Release number of selected component (if applicable):

fuseiso-20070708-12.el7.ppc64

How reproducible:


Steps to Reproduce:
1. fuseiso /path/to/image /mnt
2. ls -l /mnt
  
Actual results:

# fuseiso Fedora-17-x86_64-netinst.iso /mnt
isofs_read_raw_block: can`t read full block, read only 0 bytes from offset 0, 8 required; errno 0, message Success
isofs_read_raw_block: huh? reading zeros beyond file end? someone want to save a penny?
check_rr: directory record length too small: 0
isofs_read_raw_block: can`t read full block, read only 0 bytes from offset 0, 8 required; errno 0, message Success
isofs_read_raw_block: huh? reading zeros beyond file end? someone want to save a penny?
check_rr: directory record length too small: 0
# ls -l /mnt
ls: reading directory /mnt: Input/output error

Expected results:

Directory listing with the contents of the ISO image.

Comment 1 Tom "spot" Callaway 2013-12-05 15:56:35 UTC
I have no access to a ppc64 to even begin to try to fix this.

Comment 2 Florian Weimer 2013-12-10 09:55:29 UTC
(In reply to Tom "spot" Callaway from comment #1)
> I have no access to a ppc64 to even begin to try to fix this.

Please see this wiki page for requesting shell access:

https://fedoraproject.org/wiki/Architectures/PowerPC#PPC_Shell_access_for_debugging

Comment 3 Zeeshan Ali 2013-12-11 14:37:23 UTC
(In reply to Tom "spot" Callaway from comment #1)
> I have no access to a ppc64 to even begin to try to fix this.

Since fuseiso is mainly required by gnome-boxes(?) and that doesn't build for PPC64, I'd suggest we just don't build this for PPC64 either. We intent to move away from fuseiso in Boxes.

Comment 4 Florian Weimer 2014-09-09 08:59:05 UTC
(In reply to Zeeshan Ali from comment #3)
> Since fuseiso is mainly required by gnome-boxes(?) and that doesn't build
> for PPC64, I'd suggest we just don't build this for PPC64 either.

gnome-boxes is now built on ppc64, too, so this is no longer an option.

> We intent to move away from fuseiso in Boxes.

Any ETA on this?  Is fuseiso useful for anything at all these days, with image mounting via udisks2?

Comment 5 Zeeshan Ali 2014-09-10 16:28:42 UTC
(In reply to Florian Weimer from comment #4)
> (In reply to Zeeshan Ali from comment #3)
> > Since fuseiso is mainly required by gnome-boxes(?) and that doesn't build
> > for PPC64, I'd suggest we just don't build this for PPC64 either.
> 
> gnome-boxes is now built on ppc64, too, so this is no longer an option.

Why? We have no support for that ATM AFAIK.

> > We intent to move away from fuseiso in Boxes.
> 
> Any ETA on this?  Is fuseiso useful for anything at all these days, with
> image mounting via udisks2?

Actually we removed fuseiso already in last stable release (3.12) but that unfortunately never got into Fedora. We moved to use of iso-read command instead but in the upcoming stable release (3.14), we dropped even that in favor of libarchive.

Well, anyway. I guess we can mark this as MODIFIED at least.

Comment 6 Florian Weimer 2014-10-02 12:41:08 UTC
fuseiso-20070708-16.fc21.ppc64le is still present in the distribution, has this bug, and a dependency of gnome-boxes-0:3.13.91-1.fc21.ppc64le, so I'm moving this back to NEW.

Comment 7 Fedora Update System 2014-10-02 23:17:41 UTC
gnome-boxes-3.14.0-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-boxes-3.14.0-3.fc21

Comment 8 Fedora Update System 2014-10-04 03:21:20 UTC
gnome-boxes-3.14.0-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.