Bug 864720

Summary: [abrt] systemd-analyze-194-1.fc18: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.AccessDenied: SELinux policy denies access.
Product: [Fedora] Fedora Reporter: Simon A. Erat <erat.simon>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dominick.grift, dwalsh, johannbg, lnykryn, luya, metherid, mgrepl, msekleta, notting, plautrba, systemd-maint, vpavlin
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:cf9899fa48107b43bb75404cf404393782b1bb6c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-15 05:02:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
File: dso_list
File: core_backtrace none

Description Simon A. Erat 2012-10-09 20:45:43 EDT
Version-Release number of selected component:

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
cmdline:        /usr/bin/python /bin/systemd-analyze blame
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

:connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.AccessDenied: SELinux policy denies access.
:Traceback (most recent call last):
:  File "/bin/systemd-analyze", line 309, in <module>
:    verb.get(args[0], unknown_verb)()
:  File "/bin/systemd-analyze", line 108, in blame
:    data = acquire_time_data()
:  File "/bin/systemd-analyze", line 12, in acquire_time_data
:    units = manager.ListUnits()
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
:    return self._proxy_method(*args, **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.AccessDenied: SELinux policy denies access.
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SystemBus (system) at 0x7feecae17770>
:args: ()
:object_path: '/org/freedesktop/systemd1'
:signature: None
:bus_name: dbus.UTF8String(':1.1')
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:timeout: -1.0
:kwargs: {}
:dbus_interface: 'org.freedesktop.systemd1.Manager'
:message: <dbus.lowlevel.MethodCallMessage path: /org/freedesktop/systemd1, iface: org.freedesktop.systemd1.Manager, member: ListUnits dest: :1.1>
:method: 'ListUnits'
Comment 1 Simon A. Erat 2012-10-09 20:45:47 EDT
Created attachment 624372 [details]
File: dso_list
Comment 2 Simon A. Erat 2012-10-09 20:45:49 EDT
Created attachment 624373 [details]
File: core_backtrace
Comment 3 Simon A. Erat 2012-10-10 08:53:50 EDT
setenforce 0 does 'solve' the issue as a workaround.
However, as soon setenforce 1 is set, its causing an error again.
Comment 4 Simon A. Erat 2012-10-11 11:14:31 EDT
selinux-policy: 3.11.1-32.fc18
Comment 5 Luya Tshimbalanga 2012-10-11 19:03:28 EDT
Execute systemd-analyse blame

Package: systemd-analyze-194-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 6 Luya Tshimbalanga 2012-10-11 22:22:49 EDT
selinux-policy: 3.11.1-37.fc18 from koji resolved that bug.
Comment 7 Lennart Poettering 2012-10-12 12:02:17 EDT
Reassigning to selinux-policy. Given that 3.11.1-37.fc18 fixes this issue the bug can probably be closed quickly. But it might make sense to add it to the appropriate bodhi ticket?
Comment 9 Miroslav Grepl 2012-10-15 05:02:20 EDT

*** This bug has been marked as a duplicate of bug 859614 ***