Bug 86486

Summary: RPM database corruption in failed (single) package update
Product: [Retired] Red Hat Linux Reporter: keithu <keithu>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED NOTABUG QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-28 19:45:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description keithu@parl.clemson.edu 2003-03-24 03:49:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
I ran an rpm -i for kernel-2.4.18-27.7.x and it hung (for a LONG time).  I did
Ctrl-C and tried again.  Same result.  Now, I have two entries for it in the RPM
database (and so can't remove it - rpm complains that the name specifies
multiple packages).  Now what?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fail an RPM install
2.try again
3.try to remove the RPM 
    

Additional info:

Comment 1 Jeff Johnson 2003-03-28 19:45:35 UTC
Do
   rpm -evv --allmatches kernel-X-Y
where X == the version, and Y == the release, you want to remove.

If still hanging, do
    rm -f /var/lib/rpm/__db*
first.

Comment 2 keithu@parl.clemson.edu 2003-03-28 20:22:10 UTC
Thanks.  Worked great.  BTW, do you just put the vv in there as vengence against
those who fail to RTFM? ;-)