Bug 865327

Summary: glusterd keeps listening on ipv6 interfaces for volumes when using inet familly address
Product: [Community] GlusterFS Reporter: florian.leduc
Component: glusterdAssignee: GlusterFS Bugs list <gluster-bugs>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: medium    
Version: 3.3.0CC: gluster-bugs, rwheeler
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glusterfs-3.5.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-04-17 07:39:12 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description florian.leduc 2012-10-11 04:55:39 EDT
Description of problem:

Using the option "transport.address-family inet" does not force volume to listen on ipv4 addresses. 

Version-Release number of selected component (if applicable):


How reproducible:
Often

Steps to Reproduce:
1. Set ipv6 support on interfaces on 2 machine
2. Set ipv6 addresses to your interfaces
3. Use option transport.address-family inet 
4. Probe your machines using the ipv4 addresses
5. Create a single volume (with one brick)
6. Check with netstat command that the volume is listening, port 24011 (for example) is listening on tcp6.
  

Actual results:
tcp6       0      0 :::24011                :::*                    LISTEN      0          1563400678  17713/glusterfsd

Expected results:
tcp       0      0 0.0.0:24011                0.0.0.0:*                 LISTEN      0          1563400678  17713/glusterfsd

Additional info:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.4 LTS"
Comment 1 florian.leduc 2012-10-11 04:59:15 EDT
Interfaces configuration:

auto vlan140
iface vlan140 inet static
    vlan-raw-device eth0
    address 10.234.68.38
    netmask 255.255.255.224
    up ip route add 10.0.0.0/8 via 10.234.68.33
    up ip route add 192.168.0.0/16 via 10.234.68.33
iface vlan140 inet6 static
    address 2a01:c940:b6:140::38
    netmask 64
    up ip route add 2a01:c940::/40 via 2a01:c940:b6:140::1
Comment 2 florian.leduc 2012-10-11 05:09:34 EDT
More info about this:

I've disabled ipv6 supports, stopped the volume, restarted glusterd, started back the volume and now I've got:

glusterfs 14242        root   10u  IPv4 917544705      0t0  TCP *:24009 (LISTEN)
Comment 3 Vijay Bellur 2013-02-07 19:48:47 EST
CHANGE: http://review.gluster.org/3889 (glusterfsd can't listen in a specified address) merged in master by Anand Avati (avati@redhat.com)
Comment 4 Niels de Vos 2014-04-17 07:39:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user