Bug 865437

Summary: Anaconda hangs (consumes 100% cpu without any progress) after preparing to install
Product: [Fedora] Fedora Reporter: Hedayat Vatankhah <hedayatv>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: anaconda-maint-list, g.kaviyarasu, jonathan, satellitgo, vanmeeuwen+fedora
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-03 09:35:14 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Anaconda.log
none
program.log
none
/tmp/syslog none

Description Hedayat Vatankhah 2012-10-11 09:08:59 EDT
Description of problem:
I've created a Fedora spin using pungi. After working around a number of bugs (e.g. missing hostname requires in anaconda), I'm able to go through all installation screens. Anaconda starts the installation, the preparation progress bar is completed and in GUI it says that it is going to install base filesystem package (in console, the last log message is "preparing to install"). In this stage, no further progress is made, and anaconda is using 100% cpu (as reported by top). 
I'm trying to install in KVM, but not sure if it has any relation with this problem.

Version-Release number of selected component (if applicable):
Latest packages from fedora/updates repo

How reproducible:
100%
Comment 1 Chris Lumens 2012-10-11 09:23:53 EDT
Please attach /tmp/anaconda.log, /tmp/syslog, and /tmp/progam.log to this bug report as individual, uncompressed attachments.
Comment 2 Hedayat Vatankhah 2012-10-12 16:16:19 EDT
Created attachment 626206 [details]
Anaconda.log
Comment 3 Hedayat Vatankhah 2012-10-12 16:17:01 EDT
Created attachment 626207 [details]
program.log
Comment 4 Hedayat Vatankhah 2012-10-12 16:17:40 EDT
Created attachment 626208 [details]
/tmp/syslog
Comment 5 Hedayat Vatankhah 2012-11-11 05:22:02 EST
OK, I lost my interest in this bug and decided to not build a spin from Fedora 17.
Also, I don't think that anybody would investigate it any further.
Comment 6 satellitgo 2014-11-02 15:43:37 EST
f21-workstation -Beta-RC4 Boxes hangs at "Preparing to install"
seen 2x
1-)Boot.iso in Boxes 1.2 GB memory  (waited 15 minutes)
also seen in:
2-)Booted L-i-td USB of Workstation DVD Beta RC-4  (waited 35 minutes)
Comment 7 satellitgo 2014-11-02 16:17:29 EST
(In reply to satellitgo from comment #6)
> f21-workstation -Beta-RC4 Boxes hangs at "Preparing to install"
> seen 2x
> 1-)Boot.iso in Boxes 1.2 GB memory  (waited 15 minutes)
> also seen in:
> 2-)Booted L-i-td USB of Workstation DVD Beta RC-4  (waited 35 minutes)

But Boxes: SoaS-f21-Beta-RC4 gets past this problem -and boots a liveinst install
Comment 8 David Shea 2014-11-03 09:35:14 EST

*** This bug has been marked as a duplicate of bug 1048344 ***