This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 865732

Summary: Printing a selected Page in Impress will only print an empty page
Product: [Fedora] Fedora Reporter: Joachim Backes <joachim.backes>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-12-03 09:33:44 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Joachim Backes 2012-10-12 05:23:48 EDT
Description of problem:
Open an impress document and select some page by clicking in the "slides" subwindow (on the left side). Open the print dialog by Ctrl+P. Select "Selection" in the "range and Copies" submenu.Then press the "print" button.

Result: an empty page is printed, but not the selected impress sheet.

Version-Release number of selected component (if applicable):
libreoffice-3.6.3.1-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1.See description
2.
3.
  
Actual results:
See description

Expected results:
Selected page is printed

Additional info:
Comment 1 Joachim Backes 2012-10-12 05:30:54 EDT
I forgot to say that I'm using the Libreoffice print menu.
Comment 2 David Tardon 2012-10-15 07:52:34 EDT
I think this is intended for printing a selection from a slide's content, e.g., select just a few frames or a piece of text and print that. At least that is how it works in writer.
Comment 3 Joachim Backes 2012-10-15 08:49:21 EDT
(In reply to comment #2)
> I think this is intended for printing a selection from a slide's content,
> e.g., select just a few frames or a piece of text and print that.

If I unstood you right, then a frame selection is not enough for using the "selective" print function: I've always to select some text or graphics from a frame, otherwise "selective" printing an empty sheet.

This is mistakable.

So I should refine my bug report: selecting only one line for example in the impress doc and say: print selected, then always the whole frame in which the text is located is printed, and not only the selected text.

But that is the same as printing some range of frames (restricted to 1 frame).

JB
Comment 4 Caolan McNamara 2013-12-03 09:33:44 EST
It prints the complete contents of the selected objects. We won't invest in changing this.
Comment 5 Joachim Backes 2013-12-03 10:43:52 EST
Runs well in F20 with libreoffice-4.1.3.2-8.fc20.x86_64 :-)