Bug 865922

Summary: anaconda only allows 1 DE to be selected-this is a regression from what used to occur
Product: [Fedora] Fedora Reporter: satellitgo
Component: anacondaAssignee: Máirín Duffy <duffy>
Status: CLOSED NOTABUG QA Contact: Dan Mashal <dan.mashal>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, awilliam, dan.mashal, dcantrell, duffy, get.sonic, g.kaviyarasu, jonathan, kparal, notting, pbrobinson, rdieter, robatino, satellitgo, tflink, vanmeeuwen+fedora, wwoods
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 875433 (view as bug list) Environment:
Last Closed: 2012-10-30 10:20:11 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 875433    

Description satellitgo 2012-10-12 15:58:28 EDT
Description of problem:
anaconda only allows 1 DE to be selected-this is a regression from what used to occur

Version-Release number of selected component (if applicable):
Anaconda 18.14 on netinstall and DVD
http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC3/Fedora/x86_64/iso/Fedora-18-Beta-TC3-x86_64-netinst.iso

Anaconda 18.15
http://dl.fedoraproject.org/pub/alt/qa/18/20121010_f18b-smoke7/Fedora-18b-smoke7-x86_64-netinst.iso

How reproducible:
Try to select more than on Desktop ie; Gnome and sugar-desktop
It is not possible any more
Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
install 2 DE's 

Additional info:
Comment 1 Chris Lumens 2012-10-12 16:09:50 EDT
Right, what we're going for here is trying to present Fedora as a more cohesive thing where you pick what your basic system is and then add stuff to it.  The basic system is the environment on the left, and the stuff you add to it is the add-ons on the right.  We are trying to get away from the big grab-bag of crud where you just throw together whatever.

If you really really want to do this, you can of course add packages from your installed system.
Comment 2 Ben Williams 2012-10-12 16:58:16 EDT
This is really a drawback for alot of people who setup machines for the family with different desktops or setup a lab environment 

this will add multiple hours to me installs thanks guys for not advertising this earlier.
Comment 3 Adam Williamson 2012-10-12 18:27:32 EDT
You can still do multiple desktop installs using a kickstart file, note.
Comment 4 satellitgo 2012-10-12 22:00:55 EDT
Example  kickstart files need to be supplied for all available DE's on fedora's website with instructions on how to apply them to anaconda. 
This method still seems to be a major barrier for the use case of a teacher (off the internet) in a third world classroom trying to install gnome and sugar to a students PC. The "sneaker-net" case. Can the ,ks files be combined like "yum install livecd-creator livecd-tools spin-kickstarts" ?
Comment 5 Jesse Keating 2012-10-13 02:43:05 EDT
The way the newui works you can supply a kickstart with just the %packages data.  You will be prompted for all other settings.  I believe we're going to do some work to allow putting environments into the kickstart file as well as groups and packages, eg:

%packages
@standard
@^gnome-desktop
@^kde-desktop
%end

In the above stanza, "standard" is a group, the other two are environments, matching up to the choices you see in the graphical UI.
Comment 6 Dan Mashal 2012-10-16 13:46:26 EDT
I'm reopening this bug. 

This is a really BAD idea in my personal opinion.

I have been installing all the DE's off the DVD for as long as I can remember and this is really frustrating. 

Somewhat related:

You also have to actually click the actual radio button, you cannot double click or single click any feature or addon. 

These are both really bad design choices and many people have express very serious concerns over the original issue this bug is opened about. 

What needs to happen to change the development team's mind on this?
Comment 7 Dan Mashal 2012-10-16 13:47:00 EDT
And no, I'm not going to use kickstart to do this.
Comment 8 Adam Williamson 2012-10-16 15:59:25 EDT
re commonbugs - as this is a design choice not a bug it should be documented in release notes, not commonbugs.
Comment 9 Dan Mashal 2012-10-30 05:13:21 EDT
Is this getting fixed or is this an F18 NTH and an F19 requirement?

Please reply.
Comment 10 Peter Robinson 2012-10-30 05:48:03 EDT
I'm not sure why I've been added to this bug. There was discussion somewhere about it (I don't remember where) and when I was asked I responded with as long as it can be done post install with a "yum install @some-desktop" I had no issues with it. 

I don't believe it will add multiple hours, nor do I believe it's an issue for "third world classroom trying to install gnome and sugar" as they should be doing it via a custom live image or kickstart install, neither of which are impacted by this change.
Comment 11 Dan Mashal 2012-10-30 05:49:26 EDT
You were added for your 2 cents.

And I ask you what about the normal desktop power user?
Comment 12 Peter Robinson 2012-10-30 05:55:14 EDT
(In reply to comment #11)
> You were added for your 2 cents.
> 
> And I ask you what about the normal desktop power user?

The "normal desktop power user" would be more than capable of installing a second/third/forth desktop post install using either the GUI PackageKit solution for the primary/initial desktop that they installed or via yum. It should be documented properly though.
Comment 13 Máirín Duffy 2012-10-30 10:20:11 EDT
If you need to install more than one desktop you have two options:

1) Upload a kickstart file with just a %packages section with the desktops you'd like installed listed, upload it to your fedorapople page, at syslinux hit Tab and type ks="http://username.fedorapeople.org/my.ks" and you can go through the installer with the packages you need for those desktops selected.

2) Install the desktops post-install using yum groupinstall.

The use case is accounted for so I'm closing this bug.
Comment 14 Syam 2012-12-17 09:05:31 EST
This is a serious regression.

With regard to the points in comment #10 & comment #13, how exactly does an *ordinary user* install more packages *off the DVD* post install?

Does any of the package management applications (GUI or command-line) support installing stuff from the official DVD media without requiring the user creating repo files?

Even with the command-line yum, it comes down to:
1. Mount the DVD or ISO image
2. Create a repo file in /etc/yum.repos.d to point to the mount path, making sure that it is disabled by default
3. Do: yum --disablerepo="*" --enablerepo="dvd" install foo

How exactly is this method straight forward for ordinary users?

I like the new Anaconda UI, and it seems more stream-lined. But do retain the option to customize the packages at install time. Especially since there's no simple way to install things afterwards (as opposed to Debian, if I remember correctly).

Not every PC has a high bandwidth Internet connection to justify downloading packages (that are otherwise available in the DVD) from the Internet.
Comment 15 Máirín Duffy 2012-12-17 10:39:29 EST
"This is a serious regression."

I disagree.

"Does any of the package management applications (GUI or command-line) support installing stuff from the official DVD media without requiring the user creating repo files?"

Yes, PackageKit does. See:
http://cgit.freedesktop.org/packagekit/plain/docs/media-repo.txt

Basically you insert the DVD with PackageKit open and it automatically mounts the disk, grabs the media repo off the disk, and adds it to the list of sources. This was added to Fedora in *2009*. If you find the support no longer working, please file a bug under the PackageKit package.
Comment 16 satellitgo 2012-12-18 08:21:01 EST
(In reply to comment #15)
> "This is a serious regression."
> 
> I disagree.
> 
> "Does any of the package management applications (GUI or command-line)
> support installing stuff from the official DVD media without requiring the
> user creating repo files?"
> 
> Yes, PackageKit does. See:
> http://cgit.freedesktop.org/packagekit/plain/docs/media-repo.txt
> 
> Basically you insert the DVD with PackageKit open and it automatically
> mounts the disk, grabs the media repo off the disk, and adds it to the list
> of sources. This was added to Fedora in *2009*. If you find the support no
> longer working, please file a bug under the PackageKit package.

I just tested this and could not get it to work in a fedora18 TC3 DVD Gnome3 VirtualBox install - Inserting the DVD and removing the network adapter with the VirtualBox application running (DVD selected in VirtualBox) did not let me use the repo on the DVD with a yum install command,
Comment 17 satellitgo 2012-12-18 08:34:19 EST
https://bugzilla.redhat.com/show_bug.cgi?id=888307
Filed bug under PackageKit
Comment 18 Máirín Duffy 2012-12-18 11:31:10 EST
I'm not sure that it's meant to work with the yum install command. It's meant to work with PackageKit - it's a PackageKit feature. I do not know if the implementation would carry over to yum commands.
Comment 19 Adam Williamson 2012-12-18 16:43:54 EST
PK and yum are different. Please test with pkcon or gnome-packagekit, not with yum.
Comment 20 Adam Williamson 2012-12-18 17:48:56 EST
sorry, scratch that - it looks like the feature is supposed to set up a yum repo, so if it worked, 'yum install' would work. I followed up further in 888307, the function does appear to be broken, asking GNOME team why.
Comment 21 Máirín Duffy 2012-12-19 12:57:22 EST
Hi Adam, I definitely don't know how it sets up the repo - my guess was PK might might set it up in /tmp so that it doesn't have to prompt you for the root password every time you insert an install DVD in a running system, in which case it wouldn't work with yum on the command line.