Bug 867690

Summary: [abrt]: WARNING: at arch/x86/kernel/apic/ipi.c:109 default_send_IPI_mask_logical+0xb2/0xf0()
Product: [Fedora] Fedora Reporter: Mohammad Yekrangian <yekrangian>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, martin.svihalek, w00e
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:846e4c95e6ef11677fb071a591b2bb524b6215af
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-04 10:56:05 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mohammad Yekrangian 2012-10-18 01:34:19 EDT
Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.5.4-2.fc17.i686 root=UUID=bac655d3-98ae-45de-9287-3e24b92bf1b7 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.4-2.fc17.i686

:WARNING: at arch/x86/kernel/apic/ipi.c:109 default_send_IPI_mask_logical+0xb2/0xf0()
:Hardware name: Dell System XPS 15Z
:empty IPI mask
:Modules linked in: uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media snd_hda_codec_hdmi snd_hda_codec_realtek btusb arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore bluetooth iwlwifi mac80211 cfg80211 lpc_ich mei atl1c i2c_i801 rfkill coretemp kvm_intel kvm dell_laptop dcdbas microcode dell_wmi sparse_keymap uinput crc32c_intel nouveau mxm_wmi wmi ttm i915 video i2c_algo_bit drm_kms_helper drm i2c_core
:Pid: 507, comm: udisks-part-id Not tainted 3.5.4-2.fc17.i686 #1
:Call Trace:
: [<c0438ff2>] warn_slowpath_common+0x72/0xa0
: [<c0422462>] ? default_send_IPI_mask_logical+0xb2/0xf0
: [<c0422462>] ? default_send_IPI_mask_logical+0xb2/0xf0
: [<c04390c3>] warn_slowpath_fmt+0x33/0x40
: [<c0422462>] default_send_IPI_mask_logical+0xb2/0xf0
: [<c04204b1>] native_send_call_func_ipi+0x41/0x60
: [<c048fce4>] smp_call_function_many+0x174/0x210
: [<c0566720>] ? buffer_cpu_notify+0x80/0x80
: [<c0566720>] ? buffer_cpu_notify+0x80/0x80
: [<c048fdb0>] on_each_cpu_mask+0x30/0x60
: [<c0565c00>] ? mark_buffer_async_write+0x20/0x20
: [<c048fe5c>] on_each_cpu_cond+0x7c/0x90
: [<c0566720>] ? buffer_cpu_notify+0x80/0x80
: [<c0565f4b>] invalidate_bh_lrus+0x2b/0x30
: [<c056be9b>] kill_bdev+0x1b/0x30
: [<c056cb0c>] __blkdev_put+0x4c/0x170
: [<c06110b9>] ? selinux_file_free_security+0x19/0x20
: [<c056cc79>] blkdev_put+0x49/0x100
: [<c056cd4f>] blkdev_close+0x1f/0x30
: [<c053edf6>] fput+0xe6/0x210
: [<c053b314>] filp_close+0x54/0x80
: [<c043e2a5>] put_files_struct+0x75/0xc0
: [<c043e380>] exit_files+0x40/0x50
: [<c043e7f8>] do_exit+0x178/0x800
: [<c070ddd0>] ? read_null+0x10/0x10
: [<c043f114>] do_group_exit+0x34/0xa0
: [<c043f198>] sys_exit_group+0x18/0x20
: [<c094af5f>] sysenter_do_call+0x12/0x28
Comment 1 martin.svihalek 2012-10-23 04:15:31 EDT
Immediately after start Gnome system was reporting some problem at kernel.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Mike H 2012-12-28 11:13:13 EST
Hi.  I have what appears to be the same crash in a 3.6.10 kernel on Fedora 17.

[36793.132667] ------------[ cut here ]------------
[36793.132694] WARNING: at arch/x86/kernel/apic/ipi.c:109 default_send_IPI_mask_logical+0xb2/0xf0()
[36793.132703] Hardware name: A7GM-S 2.0
[36793.132706] empty IPI mask
[36793.132710] Modules linked in: fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc bnep bluetooth rfkill be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state hwmon_vid nf_conntrack ip6table_filter ip6_tables cx88_blackbird cx2341x tuner_simple tuner_types tda9887 tda8290 tea5767 tuner cx8800 cx8802 cx88_alsa cx88xx btcx_risc tveeprom videobuf_dma_sg videobuf_core v4l2_common videodev snd_hda_codec_hdmi snd_hda_codec_realtek media snd_hda_intel snd_hda_codec rc_core snd_hwdep snd_seq snd_seq_device snd_pcm sp5100_tco i2c_piix4 snd_page_alloc snd_timer snd soundcore r8169 mii k10temp microcode vboxnetadp(O) vboxnetflt(O) vboxdrv(O) vhost_net tun macvtap macvlan kvm_amd kvm nfsd auth_rpcgss nfs_acl lockd sunrpc uinput binfmt_misc ata_generic pata_acpi pata_atiixp usb_storage radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core
[36793.132970] Pid: 9946, comm: Cache I/O Tainted: G         C O 3.6.10-2.fc17.i686.PAE #1
[36793.132974] Call Trace:
[36793.132988]  [<c044bbf2>] warn_slowpath_common+0x72/0xa0
[36793.132997]  [<c0434b02>] ? default_send_IPI_mask_logical+0xb2/0xf0
[36793.133003]  [<c0434b02>] ? default_send_IPI_mask_logical+0xb2/0xf0
[36793.133011]  [<c044bcc3>] warn_slowpath_fmt+0x33/0x40
[36793.133018]  [<c0434b02>] default_send_IPI_mask_logical+0xb2/0xf0
[36793.133027]  [<c0432ad1>] native_send_call_func_ipi+0x41/0x60
[36793.133035]  [<c04a4314>] smp_call_function_many+0x174/0x210
[36793.133045]  [<c0443ee0>] ? do_flush_tlb_all+0x50/0x50
[36793.133052]  [<c0443fbb>] native_flush_tlb_others+0x2b/0x30
[36793.133060]  [<c0444250>] flush_tlb_page+0x50/0xa0
[36793.133069]  [<c0442d76>] ptep_set_access_flags+0x66/0x80
[36793.133077]  [<c052627e>] do_wp_page+0x4ee/0x890
[36793.133086]  [<c0977060>] ? vmalloc_fault+0x176/0x176
[36793.133094]  [<c0527dc7>] handle_pte_fault+0x307/0xad0
[36793.133102]  [<c052968d>] handle_mm_fault+0x1dd/0x280
[36793.133111]  [<c058c9c9>] ? fsnotify+0x1e9/0x2d0
[36793.133118]  [<c0977060>] ? vmalloc_fault+0x176/0x176
[36793.133125]  [<c09771a1>] do_page_fault+0x141/0x450
[36793.133132]  [<c0555948>] ? vfs_write+0xe8/0x160
[36793.133139]  [<c0554e50>] ? wait_on_retry_sync_kiocb+0x50/0x50
[36793.133145]  [<c0555be9>] ? sys_write+0x59/0x70
[36793.133152]  [<c0977060>] ? vmalloc_fault+0x176/0x176
[36793.133158]  [<c0974663>] error_code+0x67/0x6c
[36793.133163] ---[ end trace d171fffb6cdddb1b ]---
Comment 3 Dave Jones 2013-01-04 10:56:05 EST

*** This bug has been marked as a duplicate of bug 867174 ***