Bug 867996

Summary: RFE: don't file xserver backtraces when nvidia is loaded
Product: [Fedora] Fedora Reporter: migu3l.vergara
Component: abrtAssignee: Denys Vlasenko <dvlasenk>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: abrt-devel-list, dvlasenk, iprikryl, jfilak, jmoskovc, kklic, mmilata, mtoman, xgl-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:bf97e4283ff982cab9db048a8ec1c533990a38e6
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-12 01:17:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: usr_share_xorg_conf_d.tar.gz
none
File: xorg.conf
none
File: Xorg.0.log
none
File: etc_X11_xorg_conf_d.tar.gz none

Description migu3l.vergara 2012-10-18 20:19:03 UTC
Version-Release number of selected component:
xorg-x11-server-Xorg-1.12.3-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
kernel:         3.6.1-1.fc17.x86_64

Comment 1 migu3l.vergara 2012-10-18 20:19:05 UTC
Created attachment 629621 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 2 migu3l.vergara 2012-10-18 20:19:07 UTC
Created attachment 629622 [details]
File: xorg.conf

Comment 3 migu3l.vergara 2012-10-18 20:19:09 UTC
Created attachment 629623 [details]
File: Xorg.0.log

Comment 4 migu3l.vergara 2012-10-18 20:19:11 UTC
Created attachment 629624 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 5 Adam Jackson 2012-10-18 21:13:12 UTC
nvidia driver lockup, notourbug.

Can abrt please not file bugs when nvidia is loaded?

Comment 6 migu3l.vergara 2012-10-18 21:26:46 UTC
sorry. didn't know.

Comment 7 Jiri Moskovcak 2012-10-19 08:34:12 UTC
Related to rhbz#856790

- should be enough to just refuse reporting Xorg crashes when the kernel is tainted

- please don't forget to add a descriptive not_reportable reason so users are informed why ABRT is refusing to report the crash. Something like:

"This $COMPONENT crash can't be reported because your kernel is tainted ($whyis the_kernel_tainted)

Comment 8 Fedora Update System 2012-12-20 11:51:29 UTC
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18

Comment 9 Fedora Update System 2012-12-21 01:31:30 UTC
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-01-12 01:18:01 UTC
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.