Bug 868127

Summary: [abrt] GDIMetaFile::ImplPlayWithRenderer (fullscreen?)
Product: [Fedora] Fedora Reporter: Yogesh Mantri <ykmantri>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:a1502619455125321648fb2a9a4f19686a033351
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-23 00:09:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: core_backtrace
none
File: environ
none
File: event_log
none
File: backtrace
none
File: limits
none
File: cgroup
none
File: maps
none
File: dso_list
none
File: var_log_messages
none
File: open_fds none

Description Yogesh Mantri 2012-10-19 02:01:53 EDT
Description of problem:
tried to do full screen and crashed.

reprocible again and again.


Version-Release number of selected component:
libreoffice-core-3.5.7.2-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer file:///home/ymantri/Documents/ccpu/Tek%20Load%20Balancer%20System%20Architecture%20Specification-latest.doc --splash-pipe=6
crash_function: GDIMetaFile::ImplPlayWithRenderer
kernel:         3.6.1-1.fc17.i686

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 GDIMetaFile::ImplPlayWithRenderer at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/gdi/gdimtf.cxx:486
: #1 GDIMetaFile::Play at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/gdi/gdimtf.cxx:639
: #2 ImpGraphic::ImplDraw at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/gdi/impgraph.cxx:842
: #3 Graphic::Draw at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/gdi/graph.cxx:596
: #4 SwNoTxtFrm::PaintPicture at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/doc/notxtfrm.cxx:985
: #5 SwNoTxtFrm::Paint at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/doc/notxtfrm.cxx:321
: #6 SwLayoutFrm::Paint at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/layout/paintfrm.cxx:3434
: #7 SwFlyFrm::Paint at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/layout/paintfrm.cxx:4123
: #8 SwFlyCntPortion::Paint at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/text/porfly.cxx:266
: #9 SwTxtPainter::DrawTextLine at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/text/itrpaint.cxx:405
Comment 1 Yogesh Mantri 2012-10-19 02:01:58 EDT
Created attachment 629782 [details]
File: core_backtrace
Comment 2 Yogesh Mantri 2012-10-19 02:02:00 EDT
Created attachment 629783 [details]
File: environ
Comment 3 Yogesh Mantri 2012-10-19 02:02:02 EDT
Created attachment 629785 [details]
File: event_log
Comment 4 Yogesh Mantri 2012-10-19 02:02:05 EDT
Created attachment 629786 [details]
File: backtrace
Comment 5 Yogesh Mantri 2012-10-19 02:02:07 EDT
Created attachment 629787 [details]
File: limits
Comment 6 Yogesh Mantri 2012-10-19 02:02:10 EDT
Created attachment 629788 [details]
File: cgroup
Comment 7 Yogesh Mantri 2012-10-19 02:02:13 EDT
Created attachment 629789 [details]
File: maps
Comment 8 Yogesh Mantri 2012-10-19 02:02:15 EDT
Created attachment 629790 [details]
File: dso_list
Comment 9 Yogesh Mantri 2012-10-19 02:02:18 EDT
Created attachment 629791 [details]
File: var_log_messages
Comment 10 Yogesh Mantri 2012-10-19 02:02:20 EDT
Created attachment 629792 [details]
File: open_fds
Comment 11 David Tardon 2012-10-19 02:58:38 EDT
This does not happen normally, so it must be related to the document you were viewing. Could you attach the file here?
Comment 12 Yogesh Mantri 2012-10-19 06:16:52 EDT
changing view to full screen view crashed libreoffice abruptly.

tried several times and d same result. reproducible many times.


backtrace_rating: 4
Package: libreoffice-core-3.5.7.2-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Yogesh Mantri 2012-10-22 11:23:44 EDT
Hi David,

Thanks for reply.

I don't remember the document. I tried several different documents and which were viewed properly in normal mode. Only when i tried to switch to full screen mode, i.e. menu-view->fullscreen, it used to crash.

Now i changed my os itself, i.e. FC17 (32bit) to FC17(64bit) & in this version, its working properly.

Thanks though.
(In reply to comment #11)
> This does not happen normally, so it must be related to the document you
> were viewing. Could you attach the file here?