Bug 869001

Summary: [abrt]: [171642.431330] WARNING: at drivers/gpu/drm/i915/i915_drv.c:440 __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]()
Product: [Fedora] Fedora Reporter: Michael Stahl <mstahl>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: ajax, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:c134c978967f1a4e624a5d13a791544e016055f4
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-04 16:50:03 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Michael Stahl 2012-10-22 13:46:31 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.11-1.fc16.x86_64 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb LANG=en_US.UTF-8

backtrace:
:[171642.431330] WARNING: at drivers/gpu/drm/i915/i915_drv.c:440 __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]()
:[171642.431336] Hardware name: 42433ZG
:[171642.431340] Modules linked in: vfat fat usblp usb_storage tun tcp_lp fuse lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_state nf_conntrack ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant arc4 btusb snd_hda_intel snd_hda_codec iwlwifi bluetooth snd_hwdep cdc_ncm mac80211 cfg80211 tpm_tis tpm tpm_bios usbnet snd_seq snd_seq_device coretemp snd_pcm i2c_i801 microcode cdc_wdm thinkpad_acpi snd_timer snd snd_page_alloc rfkill soundcore cdc_acm iTCO_wdt iTCO_vendor_support e1000e joydev mii uinput sunrpc binfmt_misc xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel firewire_ohci firewire_core crc_itu_t sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[171642.431446] Pid: 459, comm: Xorg Not tainted 3.4.11-1.fc16.x86_64 #1
:[171642.431451] Call Trace:
:[171642.431470]  [<ffffffff8105810f>] warn_slowpath_common+0x7f/0xc0
:[171642.431479]  [<ffffffff8105816a>] warn_slowpath_null+0x1a/0x20
:[171642.431500]  [<ffffffffa007794e>] __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]
:[171642.431522]  [<ffffffffa00780a2>] i915_write32+0x82/0xe0 [i915]
:[171642.431556]  [<ffffffffa00b616c>] gen6_ring_get_irq+0x9c/0xb0 [i915]
:[171642.431586]  [<ffffffffa00b6198>] blt_ring_get_irq+0x18/0x20 [i915]
:[171642.431611]  [<ffffffffa0088c16>] i915_wait_request+0x156/0x4e0 [i915]
:[171642.431636]  [<ffffffffa0089023>] ? i915_gem_flush_ring+0x43/0x1f0 [i915]
:[171642.431658]  [<ffffffffa0088fd7>] i915_gem_object_wait_rendering+0x37/0x40 [i915]
:[171642.431683]  [<ffffffffa008fc0a>] i915_gem_do_execbuffer+0xaca/0x1610 [i915]
:[171642.431693]  [<ffffffff812cc3e4>] ? timerqueue_add+0x74/0xc0
:[171642.431717]  [<ffffffffa0090c4e>] i915_gem_execbuffer2+0xae/0x290 [i915]
:[171642.431740]  [<ffffffffa00213cc>] drm_ioctl+0x47c/0x540 [drm]
:[171642.431748]  [<ffffffff8106994f>] ? recalc_sigpending+0x1f/0x60
:[171642.431773]  [<ffffffffa0090ba0>] ? i915_gem_execbuffer+0x450/0x450 [i915]
:[171642.431782]  [<ffffffff810143f4>] ? do_signal+0x194/0x5d0
:[171642.431792]  [<ffffffff811953f8>] do_vfs_ioctl+0x98/0x550
:[171642.431801]  [<ffffffff81195941>] sys_ioctl+0x91/0xa0
:[171642.431810]  [<ffffffff81606187>] ? int_check_syscall_exit_work+0x34/0x3d
:[171642.431818]  [<ffffffff81605ee9>] system_call_fastpath+0x16/0x1b
Comment 1 Dave Jones 2012-10-23 11:37:19 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 2 Michael Stahl 2012-11-07 16:46:11 EST
have not observed the bug in 10 days running 3.6.2-1.fc16

3.6 already appears more stable than 3.4 ever was
(had no stability issues with versions before 3.4 on this laptop).

resolving worksforme, will reopen if it does pop up again
Comment 3 Michael Stahl 2012-11-24 07:34:53 EST
unfortunately have to reopen it: just had this reported by ABRT again
(machine was unused at the time, doing a build of some C++ bloatware):

Linux fedorapad 3.6.6-1.fc16.x86_64 #1 SMP Mon Nov 5 16:56:43 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Nov 23 00:00:15 fedorapad kernel: [26660.717153] WARNING: at drivers/gpu/drm/i915/intel_pm.c:4059 __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]()
Nov 23 00:00:15 fedorapad kernel: [26660.717159] Hardware name: 42433ZG
Nov 23 00:00:15 fedorapad kernel: [26660.717163] Modules linked in: tun sha256_generic usb_storage tcp_lp fuse lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 ip6table_filter xt_state nf_conntrack ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant coretemp btusb bluetooth kvm snd_hda_intel snd_hda_codec cdc_acm snd_hwdep arc4 cdc_ncm snd_seq iTCO_wdt iwldvm mac80211 usbnet mii cdc_wdm microcode snd_seq_device iTCO_vendor_support iwlwifi cfg80211 joydev i2c_i801 snd_pcm tpm_tis tpm tpm_bios snd_timer thinkpad_acpi e1000e snd rfkill soundcore snd_page_alloc lpc_ich mfd_core uinput sunrpc binfmt_misc xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video
Nov 23 00:00:15 fedorapad kernel: [26660.717294] Pid: 1239, comm: Xorg Not tainted 3.6.6-1.fc16.x86_64 #1
Nov 23 00:00:15 fedorapad kernel: [26660.717299] Call Trace:
Nov 23 00:00:15 fedorapad kernel: [26660.717321]  [<ffffffff8105c69f>] warn_slowpath_common+0x7f/0xc0
Nov 23 00:00:15 fedorapad kernel: [26660.717332]  [<ffffffff8105c6fa>] warn_slowpath_null+0x1a/0x20
Nov 23 00:00:15 fedorapad kernel: [26660.717383]  [<ffffffffa00bedae>] __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717418]  [<ffffffffa007c0d8>] i915_write32+0xa8/0x140 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717464]  [<ffffffffa00c2061>] ring_write_tail+0x21/0x30 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717506]  [<ffffffffa00c3899>] intel_ring_advance+0x49/0x50 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717546]  [<ffffffffa00c3be1>] blt_ring_flush+0x91/0xa0 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717581]  [<ffffffffa008e853>] i915_gem_flush_ring+0x43/0x1f0 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717617]  [<ffffffffa0095ec3>] i915_gem_do_execbuffer+0xc03/0x13c0 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717629]  [<ffffffff8112bc1e>] ? unlock_page+0x2e/0x40
Nov 23 00:00:15 fedorapad kernel: [26660.717664]  [<ffffffffa0096b8e>] i915_gem_execbuffer2+0xae/0x290 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717709]  [<ffffffffa002232c>] drm_ioctl+0x47c/0x540 [drm]
Nov 23 00:00:15 fedorapad kernel: [26660.717747]  [<ffffffffa0096ae0>] ? i915_gem_execbuffer+0x460/0x460 [i915]
Nov 23 00:00:15 fedorapad kernel: [26660.717759]  [<ffffffff810143e3>] ? do_signal+0x193/0x620
Nov 23 00:00:15 fedorapad kernel: [26660.717770]  [<ffffffff8101ddb2>] ? fpu_finit+0x22/0x40
Nov 23 00:00:15 fedorapad kernel: [26660.717779]  [<ffffffff8101ed0b>] ? check_for_xstate+0x3b/0xc0
Nov 23 00:00:15 fedorapad kernel: [26660.717791]  [<ffffffff8119fd58>] do_vfs_ioctl+0x98/0x550
Nov 23 00:00:15 fedorapad kernel: [26660.717803]  [<ffffffff81280e90>] ? inode_has_perm.constprop.29+0x30/0x40
Nov 23 00:00:15 fedorapad kernel: [26660.717811]  [<ffffffff81282ee2>] ? file_has_perm+0x92/0xa0
Nov 23 00:00:15 fedorapad kernel: [26660.717822]  [<ffffffff811a02a1>] sys_ioctl+0x91/0xa0
Nov 23 00:00:15 fedorapad kernel: [26660.717835]  [<ffffffff81621b47>] ? int_check_syscall_exit_work+0x34/0x3d
Nov 23 00:00:15 fedorapad kernel: [26660.717846]  [<ffffffff816218a9>] system_call_fastpath+0x16/0x1b
Nov 23 00:00:15 fedorapad kernel: [26660.717852] ---[ end trace d75ea615e411d536 ]---
Comment 4 Adam Jackson 2013-01-04 16:50:03 EST

*** This bug has been marked as a duplicate of bug 772364 ***