Bug 869848

Summary: sshd.service enabled and ssh port open after install of F18 Beta TC6
Product: [Fedora] Fedora Reporter: Volker Sobek <reklov>
Component: opensshAssignee: Petr Lautrbach <plautrba>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: mattias.ellert, mgrepl, plautrba, tmraz
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-25 04:17:31 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Volker Sobek 2012-10-24 19:55:27 EDT
Description of problem:
Installed from the F18 Beta TC6 DVD, with the result that:
1. sshd.service is enabled by default
2. the ssh port is open by default

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora from a F18 Beta TC6 media
2. Reboot
  
Actual results:
The system allows remote login via ssh.

Expected results:
The system should not allow remote login unless it was explicitly enabled.
Comment 1 Tomas Mraz 2012-10-25 04:17:31 EDT
This is enabled by design. Otherwise remote installs without kickstart would not be possible.
Comment 2 Volker Sobek 2012-10-25 04:32:06 EDT
Is this new in f18? Which install method do you mean by 'remote installs without kickstart'?
Comment 3 Petr Lautrbach 2012-10-25 04:38:45 EDT
(In reply to comment #2)
> Is this new in f18?

I believe, it's enabled since Red Hat Linux times. 

> Which install method do you mean by 'remote installs without kickstart'?

e.g. vnc install http://docs.fedoraproject.org/en-US/Fedora/17/html/Installation_Guide/vncwhitepaperadded.html
Comment 4 Volker Sobek 2012-10-25 04:56:48 EDT
Thanks for the info. I just checked a fresh install of F17 and sshd.service is NOT enabled. How come?
Comment 5 Volker Sobek 2012-10-25 05:03:03 EDT
Also the docs state:

'If you want the daemon to start automatically at the boot time, type:

systemctl enable sshd.service' [0]

[0] https://docs.fedoraproject.org/en-US/Fedora/17/html/System_Administrators_Guide/s2-ssh-configuration-sshd.html
Comment 6 Petr Lautrbach 2012-10-25 05:07:26 EDT
If your F17 is installed from Live CD media, then sshd service is not enabled by default deliberately. LiveCD has root account with empty password and live cd install's just extract image to disk.
Comment 7 Volker Sobek 2012-10-25 05:27:48 EDT
(In reply to comment #6)
> If your F17 is installed from Live CD media, then sshd service is not
> enabled by default deliberately. LiveCD has root account with empty password
> and live cd install's just extract image to disk.

Yes, it was installed from a live, thanks for the clarification!