Bug 869978

Summary: %packages --default doesn't install default system, but minimal one
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: anacondaAssignee: Brian Lane <bcl>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam, g.kaviyarasu, jonathan, jsmith.fedora, mattdm, rbergero, robatino, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-14 22:18:24 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661    

Description Kamil Páral 2012-10-25 05:40:47 EDT
Description of problem:
This is a fork of bug 867367. Please read bug 867367 comment 15 through bug 867367 comment 20.

The problem is that %packages --default in kickstart should mirror interactive default anaconda package selection, according to the documentation:

     --default 
        Install the default package set. This corresponds to the package set that would be installed if no other selections were made on the package customization screen during an interactive install. 
http://fedoraproject.org/wiki/Anaconda/Kickstart#Chapter_3._Package_Selection

It used to work by looking at <default> tags in comps, but anaconda doesn't do that anymore (it uses Environments in comps now), and --default behavior was not changed.

The net result is that with %packages --default you receive a minimal installation instead of a default one. This seems like an important bug, because lot of folks might have --default in their kickstarts and it would regress substantially in Fedora 18.

On top of that, it's not easy to work around this - first you have to do an interactive installation and then take /root/anaconda-ks.cfg and use it. But the default package selection can change in time, if Environments change.


Version-Release number of selected component (if applicable):
anaconda 18.19

How reproducible:
always

Steps to Reproduce:
1. install with kickstart with %packages --default
Comment 1 Kamil Páral 2012-10-25 05:42:44 EDT
I think this could deserve Beta NTH exception, proposing.
Comment 2 Jesse Keating 2012-10-26 00:11:08 EDT
Moving this to F18Beta which is the place we propose bugs, not -accepted.
Comment 3 Kamil Páral 2012-10-26 09:09:09 EDT
(In reply to comment #2)
> Moving this to F18Beta which is the place we propose bugs, not -accepted.

I proposed it as NTH, you proposed it as a blocker instead. Either way it gets discussed, so it doesn't really much. But when proposing as a blocker, we should have some idea which release criterion this violates.
Comment 4 Adam Williamson 2012-10-26 13:41:14 EDT
The only relevant criterion appears to be "The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible" for Beta and it doesn't _really_ hit that, so I think proposed NTH was better. Let's put it back there, as that was the intent.
Comment 5 Jesse Keating 2012-10-26 14:30:06 EDT
Yeah, sorry, I had a moment of misunderstanding on how the blocker systems work.  Thanks for fixing it up.
Comment 6 Adam Williamson 2012-10-31 14:54:51 EDT
Discussed at 2012-10-31 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt . Accepted as NTH on the basis we expect %packages --default is probably the kind of thing lots of kickstart users will be using, it's an 'obvious' thing to use if you're simply looking at the instructions for writing a kickstart. And of course as it's an installer issue, it cannot be fixed with an update.

Of course, if the fix for this turns out to be too invasive, please don't pull it into the anaconda build. Especially if it has implications outside of the kickstart path, that makes it a more dangerous change.
Comment 7 Kamil Páral 2012-11-23 10:48:39 EST
Proposing as Final blocker, this would be a serious regression otherwise, as stated in comment 6.
Comment 8 Kamil Páral 2012-11-28 12:05:11 EST
+1 final blocker, "%packages --default" is a very popular way to get a default installation and probably lots of people have it in their scripts. There is also no other reliable way of achieving the same result (see last paragraph in the description).

But if anaconda changes its documentation and officially cancels this functionality (saying "%packages --default is no longer supported"), then of course it's not a blocker.
Comment 9 Adam Williamson 2012-11-29 14:51:20 EST
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . This doesn't hit the current criteria, but we are on record as saying we intend to extend the kickstart criteria according to 'experience' - i.e. bugs that come up in blocker discussion - and there was some support at the meeting for extending the criteria to cover some key kickstart parameters, like --default.

So the decision on this is deferred, and kparal will start a thread about a criterion to cover key parameters including --default.
Comment 10 Brian Lane 2012-12-07 11:20:27 EST
commit 10cd57a15081 on master. Will cherry-pick to f18-branch if it becomes a blocker.
Comment 11 Kamil Páral 2012-12-10 03:58:13 EST
Brian, we're not frozen yet. Why not to cherry-pick the patch right away? It will save us a lengthy discussion. And I'm dead sure we will agree on at least NTH for this one, if not a full blocker.
Comment 12 Adam Williamson 2012-12-10 20:02:27 EST
I'm +1 NTH for definite, if we have a fix for this, let's pull it.
Comment 13 Adam Williamson 2012-12-10 20:07:21 EST
Tim, for your notes, since we decided to do kickstart bugs case-by-case for F18, throw this back on the 'for discussion' list...
Comment 14 Jared Smith 2012-12-12 09:07:13 EST
I'm definitely +1 NTH for this one, and seriously leaning towards blocker, if for no other reason than the element of least surprise.
Comment 15 Adam Williamson 2012-12-12 13:44:19 EST
Discussed at 2012-12-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt . Accepted as a blocker. We agreed at a recent QA meeting that it was too late to define effective kickstart command criteria for F18, and we would define criteria for F19 but consider F18 kickstart issues on a purely case-by-case basis. This issue was considered serious enough to constitute a release blocker.
Comment 16 Fedora Update System 2012-12-12 14:20:13 EST
anaconda-18.37.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.2-1.fc18
Comment 17 Fedora Update System 2012-12-12 15:42:39 EST
Package anaconda-18.37.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
then log in and leave karma (feedback).
Comment 18 Adam Williamson 2012-12-13 19:32:37 EST
will check this, seems easy enough to test.
Comment 19 Adam Williamson 2012-12-13 19:57:58 EST
seems fine in smoke6. I did an interactive install, took the generated .ks, commented out all the group lines and added --default to %packages:

%packages --default
#base-x
#core
#dial-up
#firefox
#fonts
#gnome-desktop
#hardware-support
#input-methods
#multimedia
#printing
#standard

%end

ran that back through the installer, and got an 1188 package install, which is the default set.
Comment 20 Kamil Páral 2012-12-14 05:07:34 EST
Yes, it works for me too. Good job.
Comment 21 Fedora Update System 2012-12-14 22:18:27 EST
anaconda-18.37.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.