Bug 870583

Summary: NetworkManager fails to set up eth0 using dhcp on Fedora ARM ()
Product: [Fedora] Fedora Reporter: Mildred <mildred-bug.redhat>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: danw, dcbw, jklimes
Target Milestone: ---   
Target Release: ---   
Hardware: arm   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-31 08:03:03 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mildred 2012-10-26 21:59:04 EDT
Description of problem: When booting the fedora arm image (inside a LXC container inside a debian), I get the following error:

network[82]: Bringing up loopback interface:  [  OK  ]
network[82]: Bringing up interface eth0:
network[82]: (process:228): GLib-WARNING **: (gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)
network[82]: Error: No suitable device found: no device found for connection 'System eth0'.
network[82]: [FAILED]

I get the same error with nmcli:

[root@fedora-arm etc]# nmcli con up id 'System eth0'

(process:293): GLib-WARNING **: (gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)
Error: No suitable device found: no device found for connection 'System eth0'.



Version-Release number of selected component (if applicable):
Fedora-ARM downloaded from http://download.fedoraproject.org/pub/fedora-secondary/releases/17/Images/arm/Fedora-17-arm-console.tar.xz (no updates yet)

How reproducible: always
Comment 1 Jirka Klimes 2012-10-31 08:03:03 EDT

*** This bug has been marked as a duplicate of bug 870608 ***