Bug 871484

Summary: Need logging when errors are caught adding ProviderAccount
Product: [Retired] CloudForms Cloud Engine Reporter: Matt Wagner <matt.wagner>
Component: aeolus-conductorAssignee: Matt Wagner <matt.wagner>
Status: CLOSED ERRATA QA Contact: Rehana <aeolus-qa-list>
Severity: low Docs Contact:
Priority: high    
Version: 1.1.0CC: athomas, cpelland, dajohnso, dmacpher, jlaska, morazi, slinaber, tzumainn
Target Milestone: rcKeywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: aeolus-conductor-0.13.24-1.el6cf Doc Type: Bug Fix
Doc Text:
ProviderAccountsController lacked exception handling. This update logs exceptions when creating provider accounts.
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-04 15:09:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matt Wagner 2012-10-30 14:02:18 UTC
Description of problem:
Right now, ProviderAccountsController is swallowing exceptions. Beyond this being bad practice, it's making it really hard to debug #832568.

In https://bugzilla.redhat.com/show_bug.cgi?id=832568#c1 James links to a quick patch I put together, that just adds some logger.warn lines when we get an exception. Those should be added to the actual release so we can try to track this down next time it occurs.

Comment 2 Tzu-Mainn Chen 2012-10-30 16:01:47 UTC
Pushed to master/1.1:

commit b20667eefad4541fe7b6ff3d9d0b6a1fc55945dc
Author: Matt Wagner <matt.wagner@redhat.com>
Date:   Tue Oct 30 11:36:04 2012 -0400

    Log exceptions creating provider accounts
    
    Resolves https://bugzilla.redhat.com/show_bug.cgi?id=871484
    
    Signed-off-by: Tzu-Mainn Chen <tzumainn@redhat.com>
    (cherry picked from commit 61342cbe7c432ea3fcc5b3c55b4503f1ac011c1d)

Comment 5 errata-xmlrpc 2012-12-04 15:09:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html