Bug 872889

Summary: [abrt] qemu-system-x86-1.2.0-19.fc18: __memcmp_sse4_1: Process /usr/bin/qemu-kvm was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: M. Edward (Ed) Borasky <znmeb>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: amit.shah, berrange, cfergeau, crobinso, dwmw2, itamar, knoel, pbonzini, rjones, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:13c6cd94b9dc9b41ca64699c744b3096eea3c67b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-14 17:37:09 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
File: core_backtrace
File: environ
File: backtrace
File: limits
File: cgroup
File: executable
File: maps
File: dso_list
File: build_ids
File: proc_pid_status
File: open_fds
File: var_log_messages none

Description M. Edward (Ed) Borasky 2012-11-03 20:50:03 EDT
Description of problem:
1. Installed Fedora 18 64 bit TC 7 Live (GNOME) desktop
2, Ran all updates
3. Build a Lubuntu guest machine with GNOME Boxes
4. It did not shut down, so I forced it to shut down
5. I started the Lubuntu guest up again after rebooting the host and it crashed, generating this bug report.

Version-Release number of selected component:

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/qemu-kvm -name lubuntu-12.10-desktop-i386.iso -S -M pc-1.2 -cpu SandyBridge,+osxsave,+pdcm,+xtpr,+tm2,+est,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -enable-kvm -m 2016 -smp 4,sockets=1,cores=2,threads=2 -uuid 38a4e909-9413-9be0-e496-3192aa7aaa5a -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/home/znmeb/.config/libvirt/qemu/lib/lubuntu-12.10-desktop-i386.iso.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -no-kvm-pit-reinjection -no-shutdown -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/home/znmeb/.local/share/gnome-boxes/images/lubuntu-12.10-desktop-i386.iso,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/home/znmeb/ISOs/Ubuntu/lubuntu-12.10-desktop-i386.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev user,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:00:14:1f,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device AC97,id=sound0,bus=pci.0,addr=0x4 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
crash_function: __memcmp_sse4_1
kernel:         3.6.5-2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (9 frames)
: #0 __memcmp_sse4_1 at ../sysdeps/x86_64/multiarch/memcmp-sse4.S:73
: #1 qemu_spice_create_update at ui/spice-display.c:254
: #2 qemu_spice_display_refresh at ui/spice-display.c:425
: #3 dpy_refresh at /usr/src/debug/qemu-kvm-1.2.0/console.h:267
: #4 gui_update at /usr/src/debug/qemu-kvm-1.2.0/vl.c:1281
: #5 qemu_run_timers at qemu-timer.c:393
: #7 qemu_run_all_timers at qemu-timer.c:450
: #8 main_loop_wait at main-loop.c:502
: #9 main_loop at /usr/src/debug/qemu-kvm-1.2.0/vl.c:1643
Comment 1 M. Edward (Ed) Borasky 2012-11-03 20:50:09 EDT
Created attachment 637818 [details]
File: core_backtrace
Comment 2 M. Edward (Ed) Borasky 2012-11-03 20:50:10 EDT
Created attachment 637819 [details]
File: environ
Comment 3 M. Edward (Ed) Borasky 2012-11-03 20:50:12 EDT
Created attachment 637820 [details]
File: backtrace
Comment 4 M. Edward (Ed) Borasky 2012-11-03 20:50:13 EDT
Created attachment 637821 [details]
File: limits
Comment 5 M. Edward (Ed) Borasky 2012-11-03 20:50:15 EDT
Created attachment 637822 [details]
File: cgroup
Comment 6 M. Edward (Ed) Borasky 2012-11-03 20:50:17 EDT
Created attachment 637823 [details]
File: executable
Comment 7 M. Edward (Ed) Borasky 2012-11-03 20:50:18 EDT
Created attachment 637824 [details]
File: maps
Comment 8 M. Edward (Ed) Borasky 2012-11-03 20:50:20 EDT
Created attachment 637825 [details]
File: dso_list
Comment 9 M. Edward (Ed) Borasky 2012-11-03 20:50:22 EDT
Created attachment 637826 [details]
File: build_ids
Comment 10 M. Edward (Ed) Borasky 2012-11-03 20:50:23 EDT
Created attachment 637827 [details]
File: proc_pid_status
Comment 11 M. Edward (Ed) Borasky 2012-11-03 20:50:25 EDT
Created attachment 637828 [details]
File: open_fds
Comment 12 M. Edward (Ed) Borasky 2012-11-03 20:50:27 EDT
Created attachment 637829 [details]
File: var_log_messages
Comment 13 M. Edward (Ed) Borasky 2012-11-04 00:44:57 EDT
This is bizarre. I can't get this type of guest to work with Virtual Machine Manager in either Fedora 17 or 18 TC7. It looks like it installs, but when it reboots the guest it just thrashes around throwing errors. I checked the Lubuntu ISO and it's fine. I can run it on VirtualBox in Fedora 17, so I'm wondering if there's something in the Lubuntu 12.10 kernel that's messing up somewhere in the qemu-kvm layer.

I'm going to try some other guests - openSUSE 12.2 and Linux Mint 13 for sure.
Comment 14 Cole Robinson 2012-12-14 17:37:09 EST

*** This bug has been marked as a duplicate of bug 873845 ***