Bug 873001

Summary: [abrt]: WARNING: at drivers/net/wireless/iwlwifi/pcie/tx.c:495 iwl_trans_pcie_txq_disable+0x1aa/0x220 [iwlwifi](): TAINTED G WC
Product: [Fedora] Fedora Reporter: Patrick Ooooeee <patrick0000eee>
Component: kernelAssignee: Stanislaw Gruszka <sgruszka>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: emmanuel.grumbach, gansalmon, itamar, jonathan, jwboyer, kernel-maint, madhu.chinakonda, mikhail.v.gavrilov, sgruszka
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:8be3c9eeda4887b45e8bf7b902f0ec82e57059bc
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-21 22:51:37 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
iwlwifi-remove-queue-empty-warn-3.6.patch none

Description Patrick Ooooeee 2012-11-04 14:56:04 EST
Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.2-4.fc17.x86_64 root=/dev/mapper/luks-60bc93b9-4dda-4410-b9c0-88893d7844a1 ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks.uuid=luks-788b71cc-041c-45c0-9d64-90156229a4d7 KEYTABLE=us rd.luks.uuid=luks-60bc93b9-4dda-4410-b9c0-88893d7844a1 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.6.2-4.fc17.x86_64

kernel_tainted_long:
:Proprietary module has not been loaded.
:Taint on warning.
:Modules from drivers/staging are loaded.

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/pcie/tx.c:495 iwl_trans_pcie_txq_disable+0x1aa/0x220 [iwlwifi]()
:Hardware name: 2768WFW
:queue 12 isn't empty: [162,42402]
:Modules linked in: fuse lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 ip6table_filter nf_defrag_ipv4 xt_state nf_conntrack ip6_tables arc4 iwldvm mac80211 snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep btusb iwlwifi snd_seq snd_seq_device snd_pcm snd_page_alloc cdc_wdm cdc_acm cdc_ether usbnet cfg80211 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media bluetooth mii snd_timer thinkpad_acpi coretemp kvm_intel kvm rfkill snd e1000e microcode i2c_i801 mei iTCO_wdt iTCO_vendor_support lpc_ich mfd_core vboxnetadp(O) soundcore vboxnetflt(O) vboxdrv(O) uinput xts gf128mul dm_crypt firewire_ohci firewire_core crc_itu_t yenta_socket wmi video radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core
:Pid: 9052, comm: kworker/0:0 Tainted: G        WC O 3.6.2-4.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105b81f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105b916>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa048b62b>] ? iwl_read_prph+0x7b/0x90 [iwlwifi]
: [<ffffffffa0491c8a>] iwl_trans_pcie_txq_disable+0x1aa/0x220 [iwlwifi]
: [<ffffffffa05ae34f>] iwlagn_tx_agg_stop+0x27f/0x340 [iwldvm]
: [<ffffffffa05aa6e3>] iwlagn_mac_ampdu_action+0x143/0x310 [iwldvm]
: [<ffffffffa05044ec>] ___ieee80211_stop_tx_ba_session+0x11c/0x270 [mac80211]
: [<ffffffffa0504c2f>] __ieee80211_stop_tx_ba_session+0x4f/0x80 [mac80211]
: [<ffffffffa05033c2>] ieee80211_sta_tear_down_BA_sessions+0x42/0x70 [mac80211]
: [<ffffffffa05335eb>] ieee80211_set_disassoc+0xeb/0x4c0 [mac80211]
: [<ffffffffa0537ae1>] ieee80211_mgd_deauth+0x161/0x170 [mac80211]
: [<ffffffffa050d128>] ieee80211_deauth+0x18/0x20 [mac80211]
: [<ffffffffa041b4cd>] cfg80211_mlme_down+0x7d/0xd0 [cfg80211]
: [<ffffffffa041eb1b>] __cfg80211_disconnect+0x1bb/0x1d0 [cfg80211]
: [<ffffffffa0402c48>] cfg80211_netdev_notifier_call+0x558/0x630 [cfg80211]
: [<ffffffff81575607>] ? inetdev_event+0x37/0x4f0
: [<ffffffff8108e176>] ? ttwu_do_activate.constprop.81+0x66/0x70
: [<ffffffff8161e5bd>] notifier_call_chain+0x4d/0x70
: [<ffffffff8108522e>] __raw_notifier_call_chain+0xe/0x10
: [<ffffffff81085246>] raw_notifier_call_chain+0x16/0x20
: [<ffffffff81508f56>] call_netdevice_notifiers+0x36/0x60
: [<ffffffff81508fbd>] __dev_close_many+0x3d/0xc0
: [<ffffffff8150a978>] dev_close_many+0x88/0x100
: [<ffffffff8150adba>] dev_close+0x3a/0x50
: [<ffffffffa04010ae>] cfg80211_rfkill_set_block+0x6e/0xa0 [cfg80211]
: [<ffffffffa0401106>] cfg80211_rfkill_sync_work+0x26/0x30 [cfg80211]
: [<ffffffff81077ae7>] process_one_work+0x147/0x4a0
: [<ffffffffa04010e0>] ? cfg80211_rfkill_set_block+0xa0/0xa0 [cfg80211]
: [<ffffffff8107984e>] worker_thread+0x15e/0x480
: [<ffffffff810796f0>] ? manage_workers+0x2f0/0x2f0
: [<ffffffff8107ec13>] kthread+0x93/0xa0
: [<ffffffff81623884>] kernel_thread_helper+0x4/0x10
: [<ffffffff8107eb80>] ? kthread_freezable_should_stop+0x70/0x70
: [<ffffffff81623880>] ? gs_change+0x13/0x13
Comment 1 Josh Boyer 2012-11-08 15:39:06 EST
*** Bug 874759 has been marked as a duplicate of this bug. ***
Comment 2 Emmanuel Grumbach 2012-11-14 16:53:50 EST
Yep - I added this warning because I thought this case couldn't happen, and then I saw that in fact, it is perfectly possible, so I made this one:

http://git.kernel.org/?p=linux/kernel/git/iwlwifi/iwlwifi.git;a=commit;h=4e760f1ab267edcd6e4b232ff732fc9cdc659ebb
Comment 3 Stanislaw Gruszka 2012-11-15 06:22:35 EST
Created attachment 645597 [details]
iwlwifi-remove-queue-empty-warn-3.6.patch

Above patch backported to 3.6.
Comment 4 Stanislaw Gruszka 2012-11-15 06:24:35 EST
Josh, please apply above patch as fix for this bug.
Comment 5 Josh Boyer 2012-11-16 08:41:53 EST
(In reply to comment #4)
> Josh, please apply above patch as fix for this bug.

OK, done.

Is there a reason this wasn't sent to stable?
Comment 6 Stanislaw Gruszka 2012-11-16 10:25:35 EST
This patch is now iwlwifi tree, so it still can be marked CC stable and posted upstream through fixes path ...
Comment 7 Fedora Update System 2012-11-16 13:17:21 EST
kernel-3.6.6-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.6-9.fc18
Comment 8 Fedora Update System 2012-11-16 21:27:58 EST
Package kernel-3.6.6-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.6-9.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18361/kernel-3.6.6-9.fc18
then log in and leave karma (feedback).
Comment 9 Emmanuel Grumbach 2012-11-18 04:31:26 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Josh, please apply above patch as fix for this bug.
> 
> OK, done.
> 
> Is there a reason this wasn't sent to stable?
Actually I didn't realize that a stable kernel was released with the bug.
I am sending it so stable now. This patch will also be sent to 3.7.
Comment 10 Fedora Update System 2012-11-19 07:57:14 EST
kernel-3.6.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.7-1.fc18
Comment 11 Fedora Update System 2012-11-19 17:17:35 EST
kernel-3.6.7-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.7-2.fc16
Comment 12 Fedora Update System 2012-11-19 17:18:55 EST
kernel-3.6.7-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.7-2.fc17
Comment 13 Fedora Update System 2012-11-20 16:31:55 EST
kernel-3.6.7-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.7-5.fc18
Comment 14 Fedora Update System 2012-11-20 16:38:08 EST
kernel-3.6.7-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.7-4.fc17
Comment 15 Fedora Update System 2012-11-21 22:51:40 EST
kernel-3.6.7-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-11-26 23:41:45 EST
kernel-3.6.7-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-11-28 06:30:53 EST
kernel-3.6.7-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-11-28 08:29:20 EST
kernel-3.6.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.8-2.fc17
Comment 19 Fedora Update System 2012-12-01 03:27:25 EST
kernel-3.6.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.