This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 874180

Summary: The test suite fails in 110.CreateBrand.t and 920.WebSite.t
Product: [Community] Publican Reporter: Raphaël Hertzog <raphael>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.0CC: rglasz, rlandman, xma
Target Milestone: 3.1   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 3.1.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-05 22:40:45 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 661946    
Bug Blocks:    
Attachments:
Description Flags
Patch fixing test-suite
none
Patch v2 fixing the test suite none

Description Raphaël Hertzog 2012-11-07 11:19:00 EST
Created attachment 640176 [details]
Patch fixing test-suite

While packaging publican 3.0 I noticed that the test suite doesn't work because it uses some unavailable files in /usr/share/publican instead of using in-tree files the failing tests are 110.CreateBrand.t (because it doesn't override common_config / common_content) and 920.WebSite.t (because it doesn't override tmpl_path).

Please find attached a tested patch.
Comment 1 Raphaël Hertzog 2012-11-07 16:30:24 EST
Created attachment 640401 [details]
Patch v2 fixing the test suite

I attach a new version of the patch because I missed one problem. /usr/share/publican/sitetemplate is hardcoded in bin/publican. I modified the script and Publican::WebSite so that it's a parameter now and I improved the test suite to use that new parameter.
Comment 2 Jeff Fearn 2012-11-25 18:23:36 EST
Hi Raphaël, I'm going to tie this in to https://bugzilla.redhat.com/show_bug.cgi?id=661946#c1 which should make the whole 'where are things" a lot easier.
Comment 3 Jeff Fearn 2013-01-06 23:26:34 EST
This fix has been committed to the devel branch for inclusion in Publican 3.1.
Comment 4 xuezhi ma 2013-01-31 03:20:48 EST
Hi Jeff, 

I remember that QE won't test this bug, and we have add this bug in "Features not to be tested" in test plan, so please help to verify this bug and change the bug status, thanks very much