Bug 874367

Summary: Editor should warn before saving a Fuzzy translation as Approved from a keyboard shortcut
Product: [Retired] Zanata Reporter: Sean Flanigan <sflaniga>
Component: UsabilityAssignee: Alex Eng <aeng>
Status: CLOSED CURRENTRELEASE QA Contact: Ding-Yi Chen <dchen>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: aeng, zanata-bugs
Target Milestone: ---   
Target Release: 2.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 2.1-SNAPSHOT (20121129-1444) Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-26 04:06:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sean Flanigan 2012-11-08 02:47:48 UTC
Description of problem:

It appears that a number of translators have accidentally saved Fuzzy translations as Approved, without changing any text.  Occasionally this may be desirable, especially when we implement a proper approval feature, but in these cases it has led to marking incorrect translations as correct.

From what I can tell, these translators have been using Ctrl-Enter (Save as Approved and Move Down) as a way of navigating through documents, probably because the shortcut is easier to guess than Alt-K or Alt-Down (Move Down).

I think Zanata should generate a pop-up warning when Enter/Ctrl-Enter is used on a Fuzzy translation which has no text changes.  (And only in that case.  Not when some text has changed, and possibly not for the Save as Approved button.)  

This warning should suggest Alt-K or Alt-Down as safer alternatives for navigation, and it should have an option to ignore it for the rest of the session (until we implement persistent user options).

1. Yes, I want to save this Fuzzy translation as Approved.
2. Yes, yes, I know Ctrl-Enter is Save as Approved, Alt-K is Move Down.  Don't ask me again!
3. No, I didn't mean to save this Fuzzy translation as Approved.  Cancel!

Comment 2 Ding-Yi Chen 2012-11-30 04:33:58 UTC
VERIFIED with Zanata version 2.1-SNAPSHOT (20121129-1444)